If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

position:fixed in css causes strange hang, leaving unfinished rendering and grey box on div with the position: fixed

RESOLVED WORKSFORME

Status

()

Core
General
--
major
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Mark Caron, Unassigned)

Tracking

1.8 Branch
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

In Mac OSX version of Firefox I've noticed that my site would crash on the first position: fixed div, leaving a grey background and an unloaded page. Firefox would lock up. This happened with the most recent update of FF. And on my PC at work, the page loads fine in FF. Must only be an issue with the Mac version.

Reproducible: Always




Visit http://www.goalkeeper101.com/shakers/test.asp
Compare with CSS at http://www.goalkeeper101.com/shakers/
I've added screen2.css, and screen.css is identical except where I've commented out the position: fixed on #navigation at about line 255.

I can work around issue by simply making it position: absolute, but that would defeat the whole "fixed" style I was going for. A nice feature that Mozilla does correctly, until this last update on my Mac.
(Reporter)

Updated

11 years ago
Severity: normal → major
Keywords: css2, topcrash+
Version: unspecified → 2.0 Branch
This is weird. When I go to your test page in Firefox, part of the page loads, then it seems to freeze. But actions continue to work... kind of. I can change tabs and the titlebar reflects the change. I can do the same with closing tabs. The content area, and all chrome besides the titlebar seem to be frozen.

If I go to the page in Camino, everything works fine, presumably because chrome isn't made in XUL/CSS/JS.

I'm not really sure who to CC here though...
Keywords: css2, topcrash+

Comment 2

11 years ago
reporter: you used the word 'crash', but if firefox is still open, it didn't crash. could you please generate PNG/JPGs showing the problem/expected results and attach them here (don't attach PDFs).
I can only reproduce this problem on the Mac. On the trunk, it was fixed between 2006-01-25-05 and 2006-01-26-05, which means it was almost certainly fixed by bug 317375.

I'm a little bit confused by "This happened with the most recent update of FF" in comment 0. Does that just meant that you're testing the latest update, or that the problem was introduced with the latest update? I see the problem in 2.0 through 2.0.0.3, as well as in 1.5.0.10.
Component: General → General
Product: Firefox → Core
QA Contact: general → general
Hardware: Macintosh → All
Version: 2.0 Branch → 1.8 Branch
Summary: position:fixed in css causes Firefox page to crash leaving unfinished rendering and grey box on div with the position: fixed. → position:fixed in css causes strange hang, leaving unfinished rendering and grey box on div with the position: fixed

Comment 4

10 years ago
Hi all! It's now late August, and I just ran across this bug. It took me some sleuthing to determine what was going on, but this web project of mine which runs perfectly in WinXP in IE6 and 7, Opera, and Firefox -- was hanging up on the boss' Mac using Firefox. 

A Mac-using friend tested it for me, and we narrowed it down to the presence or absence of 'position: fixed;' in the CSS. He reported, "presents the page, with a blank box where the menu ought to be, and the mouse changes from arrow to linking finger in some places in it -- probably the areas where the subchoice menus are, but the browser hangs and needs to be shut down to clear it."

Here's a version using 'position: fixed;' -- http://www.sufipaths.net/test/

and another not: http://www.sufipaths.net/test/nofixed.htm

I can find out what FF version my friend is running ... but if it updates itself when needed the way FF Win does, it's likely to be the latest release.

Sure appreciate any help that can fix this issue, as my whole project will have to be re-done if it persists.

Many thanks    -- Howard

Comment 5

10 years ago
I am able to reproduce this bug in Firefox 2.0.0.11 on Mac OS X 10.4.11 with PPC. However, using a nightly build of Firefox 3.0, your websites seem to work just fine. Timeless, you're right, I think Mark meant a hang instead of a full crash--that's what happened with my Mac, anyway.  I'm going to try to attach JPG images of Mark's website.  By the way, it looks very professional.  Any way, I think that maybe someone should mark this as FIXED because it doesn't seem to be an issue in version 3.0 of Firefox.

Comment 6

10 years ago
Created attachment 292085 [details]
Screen capture of Mark's website with Ff 2.0.0.11

Comment 7

10 years ago
Created attachment 292087 [details]
Screen capture of Mark's website using Firefox 3.0 nightly build (pre-beta2)

Here's the version info:

Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b2pre)
Gecko/2007120604
Minefield/3.0b2pre

Comment 8

10 years ago
Agree with FIXED. I don't have a Mac but according to those who do, the hang  no longer happens        -- Howard

Comment 9

10 years ago
note we'd use "WORKSFORME" unless we can point to a code change that fixed it.

Comment 10

9 years ago
If this bug is not actually fixed, please reopen this report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.