Closed Bug 375594 Opened 16 years ago Closed 15 years ago

Hebrew text replaced by katakana (or other) character when preceded by \x1c, \x1d or \x1e in RTL context

Categories

(Core :: Layout: Text and Fonts, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: uriber, Unassigned)

References

()

Details

(Keywords: regression, rtl, testcase)

Attachments

(2 files)

Attached file testcase
In the URL above, notice that the penultimate paragraph is missing its beginning (up to the first numbers), and instead has a single katakana character. That paragraph has a \x1e character before its first "real" character.

The attached testcase shows that this happens with \x1c and \x1d as well (and that it happens also when these characters appear as html numeric entities). The testcase shows a different katakana char than the page on Haaretz, for \x1c and \x1e, and a different character (possibly a double angle quotation mark) for \x1d.

I'm guessing this might be Mac-specific.
Attached image screenshot
This regressed between 2007-03-04 and 2007-03-05, so probably due to bug 370588.
Blocks: 370588
This WFM in a current trunk build.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: layout.bidi → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.