Background styling of HTML MIME parts are applied to entire message

RESOLVED DUPLICATE of bug 76804

Status

RESOLVED DUPLICATE of bug 76804
12 years ago
12 years ago

People

(Reporter: crow, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 2.0pre (20070327)

When viewing a multipart-mixed message that has an HTML MIME part that specifies some styling for the background (e.g. <body bgcolor="red">), the style is applied to the entire message window and not just the portion of the message window displaying the HTML part.

The following email messages shows the behavior:

From: joe@example.com
To: joe@example.com
Subject: Test Message
MIME-Version: 1.0
Content-Type: multipart/mixed;
        boundary="----"

------
Content-Type: text/plain

Plain Text MIME Part

This is a plain text MIME part and should not have a red background.

------
Content-Type: text/html

<body bgcolor="red">
  <h1>HTML MIME Part</h1>
  <p>This is an HTML content part with a red background.</p>
</body>

------

While I am reporting this against TB 2.0pre, I have seen it in previous versions, too.

Reproducible: Always

Steps to Reproduce:
1. Find a way to send your self the mail message above (on a UNIX system, place it into a file and run "sendmail user@domain.com < file" where user@domain.com is your email address.
2. View the message in Thunderbird.
Actual Results:  
The text portion of the email has a red background.

Expected Results:  
Only the html portion of the email should have a red background.  The text portion should be whatever it would for a plain text email.

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 76804
You need to log in before you can comment on or make changes to this bug.