Wrong text if non ASCII characters in mailto: link

UNCONFIRMED
Assigned to

Status

()

Core
Internationalization
--
major
UNCONFIRMED
11 years ago
11 years ago

People

(Reporter: Anton Shevtsov, Assigned: smontagu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; ru; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; ru; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

After click on link

<a href="mailto:&quot;Шевцов,%20Антон%20Юрьевич&quot;&lt;mail@domain.ru&gt;">mail@domain.ru</a>

opened mail client with wrong text (in To: field)
"Шевцов, Антон Юрьевич"<shev_ay@geoseis.ru>

p.s. html-page in windows-1251 encoding
p.p.s. Error was only in the presence of non ascii characters in the link
p.p.p.s. in Internet Explorer & Opera all is correct


Reproducible: Always

Steps to Reproduce:
1. create *.html file
2. insert follow text - <a href="mailto:&quot;Шевцов,%20Антон%20Юрьевич&quot;&lt;mail@domain.ru&gt;">mail@domain.ru</a>
3. open *.html file in Firefox and click on link
Actual Results:  
see Details


browser: firefox 2.0.3
email-client: The Bat 1.6
(Reporter)

Comment 1

11 years ago
Created attachment 259869 [details]
preview
(Reporter)

Updated

11 years ago
Severity: normal → major
Anton, can you please attach a testcase using the "Add an attachment" link on this page?
(Reporter)

Comment 3

11 years ago
Created attachment 259977 [details]
test file

Source code: html,windows-1251
(Reporter)

Comment 4

11 years ago
Created attachment 259978 [details]
test file

update
Thanks for the testcase Anton.

I can reproduce this on Windows XP using Firefox 2.0.0.3 and Outlook Express. If I use Thunderbird 2.0pre, however, this shows the Cyrillic characters just fine. Reproducing this bug depends on which mail client you use.

Anyway, I'm going to move this to core where someone more familiar with internationalization can look at it.

(Note: The second testcase has the encoding set. The first needs to be set manually.)
Assignee: nobody → smontagu
Component: General → Internationalization
Product: Firefox → Core
QA Contact: general → i18n
fwiw, I can also reproduce this using the latest Minefield on Windows.
You need to log in before you can comment on or make changes to this bug.