SVG images are absolutelly unusable in Gecko based browsers

RESOLVED DUPLICATE of bug 358930

Status

()

Core
SVG
--
major
RESOLVED DUPLICATE of bug 358930
11 years ago
11 years ago

People

(Reporter: FReeZ, Unassigned)

Tracking

1.8 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Opera/9.10 (X11; Linux i686; U; en)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2) Gecko/20070225 BonEcho/2.0.0.2

Dear developers,
i really wonder why FireFox still cannot render 75% of SVG images and/or for example attached one. There are serveral usefull, opensource and fully working libraries in GNU/Linux, so why you don't like them? I would like to ask you what can i do with this problem, because Opera browser renders every SVG properly and quite every other program in my Gentoo as well. I've not seen *any* correctly rendered SVG image in mozilla yet and that's very bad for my web pages which should be mozilla friendly.

Reproducible: Always

Steps to Reproduce:
1. Open the attached svg image please
Actual Results:  
The right bottom part of image is missing

Expected Results:  
The whole image should be rendered as SVG specification suggests

N/A
(Reporter)

Comment 1

11 years ago
Created attachment 259883 [details]
Example of SVG image
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0 Branch
That SVG shows identically for me in Firefox and Opera on Windows. I had a friend on Linux confirm that it also shows for him. I'm not sure what could be stopping it from working for you.
Assignee: nobody → general
Component: General → SVG
Product: Firefox → Core
QA Contact: general → ian
Version: 2.0 Branch → 1.8 Branch
(Reporter)

Comment 3

11 years ago
Created attachment 259886 [details]
Screenshot

Well, i hope you are right, here is a screenshot of incorrectly rendered image. What version of FireFox / BonEcho works for you or your friend on GNU/Linux?

Comment 4

11 years ago
This renders properly with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20061020 Minefield/3.0a1

I guess this is fixed.
Ah, from the screenshot this looks like bug 358930.

To answer your question, Firefox 2.0.0.3.
Depends on: 358930
(Reporter)

Comment 6

11 years ago
Created attachment 259893 [details]
Screenshot of SVG image in FF 2.0.0.3

I've just finished the emerging of FF 2.0.0.3, thanks for your suggestions, but it does not solved the problem. I've cleaned the cache also...
Attachment #259886 - Attachment is obsolete: true

Comment 7

11 years ago
I can confirm the reported display problem here with both:
Firefox 2.0.0.3: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.3) Gecko/20070310
Galeon: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.10) Gecko/20070209 

As I mentioned, there is no problem with the Minefield from above, which renders (correctly) exactly the same as Opera 9.10.

So, it looks to me that this bug is "fixed" on minefield branch.

On the other hand: firefox 2.0.0.3, minefield 20061020, and Opera 9.10 all fail to render properly the testcase @ bug 358930.

So, I'm not really sure this is related...

Comment 8

11 years ago
The svg image is rendered perfectly with my Firefox 2.0.0.3 (official mozilla binary) : Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

and with Minefield (trunk version, compiled by me) : Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a4pre) Gecko/20070327 Minefield/3.0a4pre

So no problem for me.

>There are serveral usefull, opensource and fully working
libraries in GNU/Linux, so why you don't like them?

Because to hard to integrate them into the DOM system of Mozilla. And because with this libraries, you cannot do somethings like embed svg tags into XBL, you couldn't call SVG DOM through javascript etc.. (see in http://croczilla.com/svg/samples example like tetris, XBL shapes, XUL+SVG...)

Comment 9

11 years ago
Confirming laurentj report: official Mozilla firefox 2.0.0.3 binaries are working just fine.

Problem occurs with 2.0.0.x distro compiled binaries (and obviously with other products, such as Galeon).

laurentj: maybe you can test it with an ubuntu package (dunno how they relate to upstream nowadays)?

FReeZ: can you please test an official mozilla build instead of emerging it?
(Reporter)

Comment 10

11 years ago
Well Oliver, i'm going to test in now.
(Reporter)

Comment 11

11 years ago
Original binaries works perfectly (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 358930
You need to log in before you can comment on or make changes to this bug.