Calendar Fails on 'Subscribe' and insists on 'read-only'

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: kevintdriver+bugzilla, Unassigned)

Tracking

Trunk
x86
Windows XP

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070327 Minefield/3.0a4pre
Build Identifier: 2007032804

My calendar fails on subscribe and on Sunbird start-up to load remotely.  I'm happy to provide a URL to developers, etc.  

Here is the description from the error console: 

Error: [Exception... "Component returned failure code: 0x804a0001 [calIRecurrenceItem.icalProperty]"  nsresult: "0x804a0001 (<unknown>)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Sunbird/js/calItemBase.js :: anonymous :: line 586"  data: no]
Source File: file:///C:/Program%20Files/Mozilla%20Sunbird/js/calItemBase.js
Line: 586

Reproducible: Always

Steps to Reproduce:
1. Subscribe to my calendar (ICS) or load Sunbird with subscription
2. Error window
3.
Actual Results:  
A pop-up displays: 
There has been an error reading data for calendar: Meetings. It has been placed in read-only mode, since changes to this calendar will likely result in data-loss.  You may change this setting by choosing 'Edit Calendar'.

When I open the error console, it displays:
Error: [Exception... "Component returned failure code: 0x804a0001 [calIRecurrenceItem.icalProperty]"  nsresult: "0x804a0001 (<unknown>)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Sunbird/js/calItemBase.js :: anonymous :: line 586"  data: no]
Source File: file:///C:/Program%20Files/Mozilla%20Sunbird/js/calItemBase.js
Line: 586
(Reporter)

Updated

12 years ago
Version: unspecified → Trunk
This seems to be the same error as in Bug 365812.
Subscribing to the calendar gives the INVALID_TIMEZONE error in Sunbird/0.5pre (20070405).

Importing the calendar shows the error message 'An unknown and undefined timezone was found while reading [...]\basic.ics.'.

There are two events in the calendar using a TZID=US/Central. But there is no corresponding VTIMEZONE defined in the ics file -> File is invalid
Whiteboard: [qa discussion needed]

Comment 3

12 years ago
Sunbird is working properly.  Reporter, the ICS you're using is malformed.

Marking INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 4

12 years ago
Sunbird is working properly.  Reporter, the ICS you're using is malformed.

Marking INVALID
Whiteboard: [qa discussion needed]
You need to log in before you can comment on or make changes to this bug.