regression: submission replace instance with method=post broken

RESOLVED FIXED

Status

Core Graveyard
XForms
RESOLVED FIXED
10 years ago
9 months ago

People

(Reporter: aaronr, Assigned: aaronr)

Tracking

({fixed1.8.0.12, fixed1.8.1.4})

Trunk
x86
All
fixed1.8.0.12, fixed1.8.1.4

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

5.07 KB, patch
smaug
: review+
Doron Rosenberg (IBM)
: review+
Details | Diff | Splinter Review
(Assignee)

Description

10 years ago
Looks like I regressed submission with my patch for bug 357901.

There is a comment in the code that SetUploadStream will set the request header to have method 'put', but I completely missed that when I moved the post submission logic to execute sooner in the ::SendData method.  I did that since we already had the httpChannel at that point.

To fix this regression, I moved the code back to after the call to SetUploadStream and moved the httpChannel variable out in scope so that it can be used later, too, without having to do another QI.
(Assignee)

Comment 1

10 years ago
Created attachment 259953 [details] [diff] [review]
patch
Attachment #259953 - Flags: review?(Olli.Pettay)
(Assignee)

Updated

10 years ago
Attachment #259953 - Flags: review?(doronr)

Updated

10 years ago
Attachment #259953 - Flags: review?(Olli.Pettay) → review+
(Assignee)

Updated

10 years ago
Blocks: 353738

Updated

10 years ago
Attachment #259953 - Flags: review?(doronr) → review+
(Assignee)

Comment 2

10 years ago
checked into trunk
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: xf-to-branch
(Assignee)

Comment 3

10 years ago
checked into 1.8 branch on 2007-04-12
checked into 1.8.0 branch on 2007-04-16
Keywords: fixed1.8.0.12, fixed1.8.1.4
Whiteboard: xf-to-branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.