Closed Bug 375788 Opened 16 years ago Closed 15 years ago

Stitch Repack, Update Generation, and Verification Steps together in Buildbot

Categories

(Release Engineering :: General, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 355309

People

(Reporter: mtschrep, Assigned: joduinn)

References

Details

Attachments

(2 files)

As part of our Build automation run we need to develop BB steps to do Repacks, Update Generation and Verification.
OS: Mac OS X → All
Hardware: PC → All
The current milestone bumping logic will always cause the automation to die();

The relevant part is:

http://lxr.mozilla.org/mozilla/source/tools/release/Bootstrap/Step/Tag/Bump.pm#76

The code will search for $versionString . 'pre' in the milestone.txt file, which it will never find (milestone.txt contains the gecko version, not the product version), and thus it will always hit the assertion.

This needs to be fixed before we can get steps working for any of the steps (including Build).
Depends on: 372759
Depends on: 378226
needed for "release automation", hence marking as critical.
Severity: normal → critical
Priority: -- → P1
Priority: P1 → P2
Down to P3 for this triage round.
Priority: P2 → P3
Update summary and reassigning to joduinn; he's going to take a look at this.
Assignee: preed → joduinn
Summary: Implement Repack, Update Generation, and Verification Steps in Buildbot → Stitch Repack, Update Generation, and Verification Steps together in Buildbot
Priority: P3 → P2
Stitching these steps together only makes sense now in the context of stitching all the build&release steps together. 

In bug#355309, there are two master.cfg files, one used for production, one used for staging, which were used to successfully create the FF2.0.0.7rc1 build last week. Those master.cfg files use more general purpose slaves, rather then step-specific slaves presented in both attachments here. Therefore marking this bug as a dup of bug#355309.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: end2end-bld
QA Contact: mozpreed → build
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.