Last Comment Bug 375878 - Remove users of ::Recycle
: Remove users of ::Recycle
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: String (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: (dormant account)
:
: Nathan Froyd [:froydnj]
Mentors:
http://lxr.mozilla.org/seamonkey/sour...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-29 12:45 PDT by Christian :Biesinger (don't email me, ping me on IRC)
Modified: 2007-03-30 15:45 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
should get most of them (2.69 KB, patch)
2007-03-29 16:55 PDT, (dormant account)
cbiesinger: review+
cbiesinger: superreview+
Details | Diff | Splinter Review

Description Christian :Biesinger (don't email me, ping me on IRC) 2007-03-29 12:45:21 PDT
225  * Deprecated: don't use |Recycle|, just call |nsMemory::Free| directly
226  *
227  * Return the given buffer to the heap manager. Calls allocator::Free()
228  */
229 inline void Recycle( char* aBuffer) { nsMemory::Free(aBuffer); }
230 inline void Recycle( PRUnichar* aBuffer) { nsMemory::Free(aBuffer); }

seems like we should remove them. (nsMemory::Free has since been deprecated by NS_Free)
Comment 1 (dormant account) 2007-03-29 16:55:05 PDT
Created attachment 260075 [details] [diff] [review]
should get most of them

Here is my first stab at it.
Comment 2 Christian :Biesinger (don't email me, ping me on IRC) 2007-03-30 15:45:01 PDT
the search parts were fixed by Bug 374862; I checked the rest in:

Checking in editor/libeditor/html/nsHTMLEditor.cpp;
/cvsroot/mozilla/editor/libeditor/html/nsHTMLEditor.cpp,v  <--  nsHTMLEditor.cpp
new revision: 1.548; previous revision: 1.547
done
Checking in netwerk/streamconv/converters/nsDirIndexParser.cpp;
/cvsroot/mozilla/netwerk/streamconv/converters/nsDirIndexParser.cpp,v  <--  nsDirIndexParser.cpp
new revision: 1.21; previous revision: 1.20
done
Checking in rdf/datasource/src/nsFileSystemDataSource.cpp;
/cvsroot/mozilla/rdf/datasource/src/nsFileSystemDataSource.cpp,v  <--  nsFileSystemDataSource.cpp
new revision: 1.147; previous revision: 1.146
done
Checking in security/manager/ssl/src/nsNSSCallbacks.cpp;
/cvsroot/mozilla/security/manager/ssl/src/nsNSSCallbacks.cpp,v  <--  nsNSSCallbacks.cpp
new revision: 1.48; previous revision: 1.47
done
Checking in xpinstall/src/nsInstallExecute.cpp;
/cvsroot/mozilla/xpinstall/src/nsInstallExecute.cpp,v  <--  nsInstallExecute.cpp
new revision: 1.33; previous revision: 1.32
done
Checking in xpinstall/src/nsInstallFile.cpp;
/cvsroot/mozilla/xpinstall/src/nsInstallFile.cpp,v  <--  nsInstallFile.cpp
new revision: 1.71; previous revision: 1.70
done
Checking in xpinstall/src/nsInstallUninstall.cpp;
/cvsroot/mozilla/xpinstall/src/nsInstallUninstall.cpp,v  <--  nsInstallUninstall.cpp
new revision: 1.27; previous revision: 1.26
done
Checking in xpinstall/src/nsJSInstall.cpp;
/cvsroot/mozilla/xpinstall/src/nsJSInstall.cpp,v  <--  nsJSInstall.cpp
new revision: 1.125; previous revision: 1.124
done

Note You need to log in before you can comment on or make changes to this bug.