Error when installing signed Japanese RC1 Build on Vista

RESOLVED DUPLICATE of bug 404609

Status

Thunderbird
Installer
RESOLVED DUPLICATE of bug 404609
11 years ago
10 years ago

People

(Reporter: Scott MacGregor, Assigned: rstrong)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Downloaded the signed japanese RC1 build in vista.

Ran the installer. Noticed that I didn't get the unknown publisher prompt (nice!)

The program installed correctly. I chose to not launch thunderbird after the installer completed.

Clicked finish.

Vista brought up a Program Compatibility Assistant dialog:

This program didn't install correctly, try reinstalling  using settings that are compat8ible with this version of Windows.

Program: Firefox
Publisher: Mozilla
Location: ....
(Reporter)

Comment 1

11 years ago
Jay / Rob, Seth tells me that the two of you saw and worked on a similar issue for Firefox in Vista. Do you remember what it was? 
(Reporter)

Comment 2

11 years ago
I tried installing the japanese RC build several times and saw this error every time.

Oddly enough, I downloaded a japanese nightly branch build, installed that. Did not see this problem. And even after uninstalling that branch build, installing the RC works correctly. 

cc'ing Marcia. This is something we can hopefully get some test day helpers to help us look at.
Flags: blocking-thunderbird2?
This happens when you install the same version two or more times (doesn't matter which locale) because Vista tests to see if the installer creates a new entry in the uninstall reg key. So, when installing the same version a second time it doesn't always see that we delete the old key as soon as possible during install and then re-add it. I've asked MS about this and so far there is no work around for this except to use MSI's. This also tends to occur when doing the second or more install during the same OS user session.
(Reporter)

Comment 4

11 years ago
Rob, thanks for filling me in on this, glad to know it's not something we have to worry about in the short term :)

Updated

11 years ago
Flags: blocking-thunderbird2?
QA Contact: build → build-config
(In reply to comment #3)
> This happens when you install the same version two or more times (doesn't
> matter which locale) because Vista tests to see if the installer creates a new
> entry in the uninstall reg key. So, when installing the same version a second
> time it doesn't always see that we delete the old key as soon as possible
> during install and then re-add it. I've asked MS about this and so far there is
> no work around for this except to use MSI's. This also tends to occur when
> doing the second or more install during the same OS user session.
> 
Rob (Strong), is this something we have to worry about still? or maybe deal with for Thunderbird 3.
I believe if the installer is built with a manifest it will be fixed and as comment #3 states it is a minor issue in that nothing is broken in the process. As for Thunderbird 3 there is a significant amount of installer / uninstaller work to be done and much of the work requires adding a manifest which would fix this.

Comment 7

10 years ago
Ref comment #3, thank you for the background on this Vista annouance that some other products (Non-Mozilla) have triggered.  Some HP Installers have the problem.

During the past three weeks of installing the Tb 3.0a1pre, a1, and a2pre builds this issue has not popped up on Vista Home Basic. Is this a different case than the one Scott reported?
Rob (Strong), is the Thunderbird 3 work you are talking about basically 'porting' the Firefox Vista installer changes on bug 370571 and the related improvements in bug 399381 to Thunderbird?

There are a number of other installer bugs that had Firefox-specific logic that seem like they are candidates for porting as well... uninstall in-use files (bug 398036, bug 408314), clean user data on uninstall (bug 398434, bug 424999), clean updates on uninstall (bug 392150), and perhaps user default app (bug 392137).  I'm not sure if Thunderbird would want the partner-inspired brand name functionality and follow-ons (bug 399665, bug 423997, bug 402999), the java happy bug (bug 400467), or talkback removal (bug 388932).

Note: I'm not trying to turn this into a tracker bug, just provide info relevant to my question...

Updated

10 years ago
Assignee: mscott → bugmail
Moving to installer as that is a better component that build-config for this bug.
Component: Build Config → Installer
QA Contact: build-config → installer
Robert Strong's changes on bug 404609 resolved this.
Assignee: bugmail → robert.bugzilla
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 404609
You need to log in before you can comment on or make changes to this bug.