Bookmark Search: can't delete; Move actually copies

RESOLVED DUPLICATE of bug 81893

Status

SeaMonkey
Bookmarks & History
RESOLVED DUPLICATE of bug 81893
11 years ago
8 years ago

People

(Reporter: Steve Snyder, Unassigned)

Tracking

SeaMonkey 1.1 Branch
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Seen while attemping to remove a duplicate bookmark:

1. From within Bookmark Manager, enter term in Search edit field, resulting in 2 bookmarks being found.  The Delete option is greyed-out in both the context menu and the menu bar, so I am unable to delete 1 of the dupes.

2. Since deletion isn't allowed, go to clever backup scheme.  Select Move... from either the context menu or the menu bar. When "Choose Folder" dialog comes up, create new folder named Trash.  Back in the "Choose Folder" dialog, select the Trash folder and click OK.  In Bookmark Manager, note that the bookmark selected has *not* been moved but just copied to Trash.  Now I have 3 copies of the duplicate bookmark.  The Trash folder can be deleted, along with it's contents, leaving me with the 2 originals.  A Move done from within the main Bookmark Manager window actually does move the bookmark to the destination folder.

The above behavior is seen with SeaMomkey v1.0.8 in Linux(FC6) and SeaMonkey v1.1.1 in WinXP(SP2).

Please do not mark this as a duplicate of bug 81893.  I am not seeing any crashes and I don't want this genuine problem to get lost in the 5-year-long dithering that has left that bug still marked as New.  Thank you.
Point 1 should be fixed when bug 123679 is fixed, setting dependency.
Depends on: 123679
Update: Neil chose to fix bug 123679 differently so this one is not fixed by that one. My patch on that bug should still work, though. The correct bug for point 1 is now bug 81893.
Depends on: 81893
No longer depends on: 81893
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 81893
You need to log in before you can comment on or make changes to this bug.