if proxy not set up correctly: can not attach a 'Web Page' as attachment (no error dialog)

NEW
Unassigned

Status

Thunderbird
Message Compose Window
--
enhancement
11 years ago
4 years ago

People

(Reporter: lijuan wang, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.8.1.3) Gecko/20070327 Firefox/2.0.0.3
Build Identifier: 

Can not attach a 'Web Page' as attachment

Reproducible: Always

Steps to Reproduce:
Thunderbird version 2 beta 2 (20070326)
Test base on Vermillion_62_devel_X86

1.Open a mail compose window
2.Select 'Web Page' in popdown menu of 'Attach' 
3.Pop out a 'Please specify a location to attach', input a web page like 'http://www.google.com'
4.Click 'Send'

Actual Results:  
After#4: Continuously 'Attaching http://www.google.com'.
The status is always 'Attaching http://www.google.com'.
Sending failed.

Expected Results:  
Web page can be attached and mail is sent out successfully.

Comment 1

11 years ago
Sends fine on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4pre) Gecko/20070329 Thunderbird/2.0.0.0pre ID:2007032903

Comment 2

11 years ago
I can also reproduce this with TB 2.0b2(version 2 beta 2 (20070123)) and nightly(version 3 alpha 1 (20070401)) on Solaris Nevada 56.

=> Confirm this.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

11 years ago
Oops, I should have done the test with proxy setting properly. This seems to be related.

Comment 4

11 years ago
Works for me when I set the proxy properly.

lijuan, I assume that the proxy wasn't set properly when the mail was sent. Could you set the http proxy in Preferences->Advanced->Network & Disk Space->Connection and try again?

Comment 5

11 years ago
After discussing with lijuan, mark the bug as WFM.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Comment 6

11 years ago
Reopen this bug as an Enhancement bug. Also change the platform to all platform. It happened on Linux, Solaris, and Windows. The problem is when send a message attached with webpage without set up the proxy, there is no reminder to user and will keep attaching web pages. The request for enhancement is add a timeout for this action and give user a reminder. 

Test cases for this enhancement bug:
Pre-condition: Make sure you need set up proxy server for HTTP in Thunderbird 

Steps:
1. In Thunderbird, Preferences->Advanced->Network & Disk Space->Connection, make sure you DO NOT set the HTTP proxy;
2. Open a mail compose window
3. Select 'Web Page' in popdown menu of 'Attach' 
4. Pop out a 'Please specify a location to attach', input a web page like
'http://www.google.com'
5.Click 'Send'

Actual Results:  
After#5: Continuously 'Attaching http://www.google.com'.
The status is always 'Attaching http://www.google.com'.

Expected Results:
Should give user a reminder that the sending failed and timeout, suggest user to check the network setting.  
Severity: normal → enhancement
Status: RESOLVED → REOPENED
OS: SunOS → All
Resolution: WORKSFORME → ---

Comment 7

11 years ago
this may be related to Bug 142326.

Updated

11 years ago
Summary: Can not attach a 'Web Page' as attachment → if proxy not set up correctly: can not attach a 'Web Page' as attachment (no error dialog)

Updated

9 years ago
Assignee: mscott → nobody
Status: REOPENED → NEW

Updated

4 years ago
Depends on: 204250
You need to log in before you can comment on or make changes to this bug.