Closed Bug 375998 Opened 14 years ago Closed 14 years ago

Embedded table resizes when a link is clicked

Categories

(Core :: Layout: Tables, defect)

1.8 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: gabriel, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

If a link is click that is inside a cell of an embedded table with some cells set to have % widths the table will resize itself. 

Reproducible: Always

Steps to Reproduce:
1. Create a page with the source code included in the 'Additional Information' section.
2. View it in Firefox 2.0.0.3
3. click the link.

Actual Results:  
Table resizes and if the link is moved from under the mouse pointer the link is not followed.

Expected Results:  
No table resizing.
Link always followed.

Source example:
<table width="100%" border="1"><tr><td><table width="100%" border="1"><tbody><tr><td colspan="4" >embedded table embedded table embedded table embedded table </td></tr><tr ><td colspan="1" width="20%">20 percent width</td><td colspan="3" width="80%">80 percent width</td></tr><tr ><td colspan="4" >&nbsp;</td></tr><tr><td colspan="4">&nbsp;</td></tr><tr><td colspan="1">&nbsp;</td><td colspan="3" >&nbsp;</td></tr><tr><td colspan="4" >&nbsp;</td></tr><tr><td colspan="2" width="50%">50 percent width</td><td colspan="2" width="50%" >50 percent width</td></tr><tr ><td colspan="2">&nbsp;</td><td colspan="2" ><a href="#">click me</a></td></tr></tbody></table></td><td>right</td></tr></table>
WFM Mac trunk.

Do you see this bug on trunk?  If not, I think you should just mark it as worksforme unless it's a regression since Firefox 2.0.0.0.
Component: General → Layout: Tables
Product: Firefox → Core
QA Contact: general → layout.tables
Version: unspecified → 1.8 Branch
Hi Jesse,

Is this question for me? If it is I'm not sure I understand. If you want me to test it on another version I can. 

The bug has existed for a while - maybe even on 1.5 - but I've only just got round to addressing the effects it on our site.

Gabriel
You can download the Minefield builds here:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
I see it indeed move a bit in Firefox 2.0.0.3 but not anymore in trunk nightlies which are the builds with the latest patches.
This bug was fixed by bug 300030. Resolving WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
I think we've typically marked reflow-branch bugs as FIXED, not WFM.  We need to make sure this is in the test suite anyway.
Flags: in-testsuite?
Resolution: WORKSFORME → FIXED
Hi,

Can you tell me what release version the new code likely to be in?

Gabriel
Gecko 1.9 / Firefox 3.
You need to log in before you can comment on or make changes to this bug.