Address bar's fragment identifier is "sticky" when directly edited

RESOLVED DUPLICATE of bug 302575

Status

()

RESOLVED DUPLICATE of bug 302575
12 years ago
12 years ago

People

(Reporter: site-mozilla-bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Manually editing the address bar's hash (fragment identifier) prevents further updates to the hash from appearing there. This includes changes to window.location.hash, fragment links, and even the back/forward buttons.

Reproducible: Always

Steps to Reproduce:
1. Programmatically change the hash to #foo (window.location.hash or fragment link)
2. Manually change the fragment identifer to #bar (editing address bar)
3. Programmatically change the hash to #qux (window.location.hash or fragment link)
Actual Results:  
Hash in address bar is #bar.

Expected Results:  
Hash in address bar should be #qux (omitting step 2 gives this result).

This is a problem for AJAX/DHTML applications that store page state in the hash.
(Reporter)

Comment 1

12 years ago
If it isn't clear, I've provided a testcase here: http://www.brainonfire.net/lab/hash/test.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 302575
You need to log in before you can comment on or make changes to this bug.