Firefox doesn't allow you to edit the name of the file being downloaded.

VERIFIED INVALID

Status

()

Firefox
File Handling
VERIFIED INVALID
11 years ago
11 years ago

People

(Reporter: rapidfire, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Firefox will only save the file names of web pages rather then the titles.

Reproducible: Always

Actual Results:  
Firefox saves the file with its original name without giving you the choice to change it.

Expected Results:  
To be able to save the file and edit the name of it if I want to.

I know about save target as but that's annoying to have to go through two steps when it could be just one like with IE. It's also a pain to have to hunt for a file among a mass of stupidly named files.

Comment 1

11 years ago
Could you describe the steps to reproduce the problem?

Comment 2

11 years ago
the submitter created the same report for bug 376094
which itself is a dup of bug 254139
The fact you have filed bug 376127 shows that you are able to change the name of web pages as you save them so I am resolving this as WFM. If I have misunderstood then please reopen and provide more accurate steps to reproduce.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

11 years ago
>The fact you have filed bug 376127 shows that you are able to change 
the name of web pages as you save them

Are you a moron, the fact that I filed the bug means the bug doesn't exist? And you want me to file the steps? Moron the step is to save a webpage, duh. Stop being a moron.
Resolution: WORKSFORME → WONTFIX
(Reporter)

Comment 5

11 years ago
(In reply to comment #1)
> Could you describe the steps to reproduce the problem?
> 

Are you guys being anal jerks? Do you not try and save pages with firefox and not see that it doesn't allow you to save the way IE does? Stop being idiots. The step is obvious, don't ask me anymore to provide a step when I explained it elsewhere and when it's obvious. You're being time-wasting jerks. If I discover anymore bugs I'm not sure I will bother to report them and am thinking about turning off the feedback agent for pestering me over and over like this.

Leave me alone an just appreciate I'm bothering to help. I can always go back to maxthon and tell the developers to replicate what I've done with firefox and it will kick firefox in the butt since it's a much faster program.

BYE.
(Reporter)

Comment 6

11 years ago
I was trying to say a few seconds ago that I found a plugin which allowed me to bypass this problem, interestingly though when I tried to state that I wasn't able to type in this box or the location field (and it seems to have been caused by that very plugin as I tested it just before I made this statement to make sure it worked since I just installed it a little while ago.) If it happens again I will tell you.
(Reporter)

Comment 7

11 years ago
It happened again, and it leaves a little rectangle like object where the menu drops down. I can resolve it by repeating the process. The plugin is called File Title. I will tell the maker that it has a problem.
(Reporter)

Updated

11 years ago
Status: RESOLVED → VERIFIED
While we appreciate your efforts to make Firefox better, filing unclear bug reports that may well be based on the extensions you already have installed, but fail to mention in your report (since for all the rest of us, it *does* let us change the file name) and then being abusive to volunteers who are trying to help is not useful, and will not be tolerated. Be polite or begone.
Resolution: WONTFIX → INVALID
You need to log in before you can comment on or make changes to this bug.