Hidden object's content (CSS display:none;) is copied to clipboard when the selection spans across that same object

RESOLVED DUPLICATE of bug 39098

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 39098
12 years ago
12 years ago

People

(Reporter: Sporty McFly, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Opera/9.10 (Windows NT 5.1; U; en)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.9) Gecko/20061206 Firefox/1.5.0.9

If you set an object to be hidden (i.e. use the CSS display property and set it to 'none'), highlight objects spanning across that hidden object, copy the selection, and paste it; the pasted result include the hidden object's content.

The hidden object's content should not be sent to the clipboard.

Reproducible: Always

Steps to Reproduce:
1. Set an object to have a CSS diplay property of 'none' (display:none;)
2. Highlight objects spanning across the position of the hidden object
3. Copy the selection
4. Paste the copied content in any text editor
Actual Results:  
The hidden object's content is copied/pasted

Expected Results:  
The hidden object's content should not be sent to the clipboard

Only copy the non-hidden objects
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0 Branch
(Reporter)

Updated

12 years ago
Version: 2.0 Branch → unspecified
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 39098
You need to log in before you can comment on or make changes to this bug.