If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

search in message is slow

RESOLVED DUPLICATE of bug 295088

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED DUPLICATE of bug 295088
11 years ago
10 years ago

People

(Reporter: Serge, Assigned: Scott MacGregor)

Tracking

({perf})

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 1.5.0.10 (20070221)

Current search is extremely slow. Every time I search any phrase among 2000 letters it takes about a minute and get 90% from my AMD64 processor.  
I think search is most important feature besides getting and sending messages.

Reproducible: Always

Steps to Reproduce:
1. Get more then 1000 letters.
2. Try to search keyword in messages

Actual Results:  
search from 2000 letters takes a minute from am64 processor using more that 90% on this task.

Expected Results:  
I expect to get results from search in less that a second.

I suggest to use any embeddable database or text index library to make search feature reliable. I don't know  Thunderbird architecture, so I can only put open source Java libraries I used in search improvement - Apache Lucene, Apache Derby,HSQLDB, Firebird.
 I hope that Thuderbird developers can find similar library or make their own to improve search functionality.
I have no problems.
what version of thunderbird (from help|about)?
where are your messages?  imap, pop, or local folders
which search?  advanced via edit|find|search messages?  or quick search (and what settings)?
(Reporter)

Comment 2

11 years ago
I use version 1.5.0.10 as you see on the top of message.
I get my messages using pop3 (this protocol means that I can store my messages on my local machine) and they usually appears in C:\Documents and Settings\serge\Application Data\Thunderbird\Profiles\hfle2jr6.default\Mail\Local Folders\Inbox file by default.This file is about 151Mb.
both search works bad.
do file|compact folders on the account.
does it run just as fast/slow?

if there is no improvement, please describe precisely a search that is slow for you.
Version: unspecified → 1.5
(Reporter)

Comment 4

11 years ago
Compact folder procedure  makes inbox file to 100Mb from 150Mb.
As for describing process... 
Ok, I want to find word "thunderbird" in the body of all messages. I type e.g. thunderbird in the search panel, choose "search in message body" and my computer in hanging up for about minute. I've just pick up a screenshot and sent to address
@lehigh.edu 
First thought is bug 295088, delivers in Thunderbird v2. Serge, if you find it's gone in v2 please dupe this to 295088.
Component: General → Mail Window Front End
Keywords: perf
QA Contact: general → front-end
Summary: Improve search in messages functionality → search in message is slow
better with version 2?
(Reporter)

Comment 7

10 years ago
Yes, it works much better, now search takes a few seconds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Resolution: FIXED → DUPLICATE
Duplicate of bug: 295088
You need to log in before you can comment on or make changes to this bug.