xul - span in embedded html causes the element not to be display

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
3 years ago

People

(Reporter: gary_johnson_53, Unassigned)

Tracking

({regression, testcase})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

820 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070330 Minefield/3.0a4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070330 Minefield/3.0a3

<html:p><span style="color:red">html p and span style </span></html:p>

does not display
<html:p> p </html:p>
this does

Reproducible: Always

Steps to Reproduce:
test case will be attached
Actual Results:  
not display


Test Case
<?xml version="1.0"?>

<?xml-stylesheet href="chrome://browser/skin/" type="text/css"?> 
<?xml-stylesheet href="chrome://browser/content/browser.css" type="text/css"?>

<!DOCTYPE dialog SYSTEM "chrome://browser/locale/bookmarks/bookmarks.dtd">
<dialog xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul" 
xmlns:html="http://www.w3.org/1999/xhtml" 
title="imbedded html in XUL Test">


<vbox flex="1" style="background-color: #F5F5F5; color:#191970; margin: 2em; overflow:auto;">

<html:h1 class="heading"><span class="HC">html h1 class and span class </span></html:h1>

<html:h1 style="color:blue"><span style="color:red">html h1 style and span style </span></html:h1>

<html:h1><span style="color:red">html h1 and span style </span></html:h1>

<html:h1><span>html h1 and span</span></html:h1>

<html:h1 class="heading">html h1 class</html:h1>

<html:h1>html h1</html:h1>



<html:p><span style="color:red">html p and span style </span></html:p>
<html:p><span>html p and span</span></html:p>



<html:pre> 

Tested with file access
file:///C:/CBSOURCE/gj53run/jar/content/gj53run/Options/BugmyUpdate4.xul

it throws Error: uncaught exception: Permission denied to get property XPCComponents.classes
which is probably correct

Tested with chrome access
chrome://gj53run/content/Options/BugmyUpdate3.xul



Title
xul - span in embedded html causes the element not to be display  

Product
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070330 Minefield/3.0a3

O.S.: XP Home and PRO, Latest Updates

Core
Component: 	XP Toolkit/Widgets: XUL
Version: 	Trunk

Description: 

Reproducible: Always

Steps to Reproduce:
1. display this file, either from file// access or chrome
 

Actual Results:  
You cannot see some of the expected lines

Expected Results:  
You should see the expected lines


bugs in smae area
60159
247620



</html:pre>
</vbox> 

</dialog>

Updated

12 years ago
Keywords: regression
(Reporter)

Comment 1

12 years ago
This  
<html:h1><span style="color:red">html h1 style and span
style </span></html:h1>

used to work.

This works in FF 2.0.0.3 and in FF 
<html:h1><html:span style="color:red">html h1 and span style </html:span></html:h1>

- note the <html added in front of the span element

It may be a bug fix instead of a bug

Comment 2

12 years ago
Created attachment 271459 [details]
Testcase

From this testcase I'd say it looks like any element in the XUL namespace that doesn't actually exist has its contents not displayed. I don't know XUL, though, so I could very well be wrong.

Updated

12 years ago
Keywords: testcase

Updated

11 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets
Hi,

User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0

I have tested this issue on the latest Firefox release (45 Build ID 20160303134406) and on the latest Nightly (48.0a1 Build ID 20160313030418) with the testcase from comment 0 and comment 2 and it is no longer reproducible. (for the testcase from comment 2 the Remote XUL Manager addon is needed)
Considering this I will mark this issue as Resolved-WORKSFORME. If anyone can still reproduce it, feel free to reopen the issue and provide more information.

Thanks,
Cipri
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.