sample plugin won't compile

VERIFIED FIXED

Status

()

Core
Plug-ins
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Axel Hecht, Assigned: blizzard)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When trying to compile the sample plugin in
modules/plugin/test
I get the following compile error:

/tmp/mozilla/modules/plugin/test/npsimple.cpp: In function `nsresult
NSRegisterSelf(class nsISupports *, const char *)':
/tmp/mozilla/modules/plugin/test/npsimple.cpp:522: no matching function for call
to `nsString::nsString (char[36])'
../../../dist/include/nsString2.h:89: candidates are: nsString::nsString()
../../../dist/include/nsString2.h:95:                 nsString::nsString(const
nsString &)
../../../dist/include/nsString2.h:107:                 nsString::nsString(const
PRUnichar *, PRInt32)
../../../dist/include/nsString2.h:130:                 nsString::nsString
(nsSubsumeStr &)
/tmp/mozilla/modules/plugin/test/npsimple.cpp:551: no match for `nsString & +=
char[21]'
../../../dist/include/nsString2.h:521: candidates are: nsString::operator +=
(PRUnichar)
../../../dist/include/nsString2.h:525:                 nsString::operator +=
(const nsString &)
../../../dist/include/nsString2.h:526:                 nsString::operator +=
(const PRUnichar *)
make: *** [npsimple.o] Error 1


Axel

Comment 1

18 years ago
Emailed the reporter about the date of file npsimple.cpp as it seems to 
reference nsString2.h which is not in the latest copy of the code.  Similar to 
bug 31114.
(Reporter)

Comment 2

18 years ago
nsString2.h is included from nsString.h, so it's still there.
The cvs version is from today, May 2nd.
It looks like this bug is a dup of bug 31114. That is worksforme, and should be 
reopended. If this bug is marked dup, please put the uptodate info on 31114.

I looked abit on the error mesgs, and the problem is, that npsimple uses some
defines for strings, which are char[]. And nsString can't handle those.
The defines are on lines 141-144.

Axel
(Assignee)

Updated

18 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 3

18 years ago
Axel: I notice that bug 31114 is against Linux, while this one is against
Solaris. If it is working for them and not for you, then it is probably not a
duplicate of this one.

Can you confirm whether you are still having the problem documented in this report?
(Reporter)

Comment 4

18 years ago
Checked, works now, is even displaying the content.

Haven't tried for quite a while, sorry.

Axel
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 5

18 years ago
marking verified based on Axel's comment.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.