Closed Bug 376426 Opened 15 years ago Closed 12 years ago

Iframe doesn't get unpainted in this case with undo

Categories

(Core :: DOM: Editor, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: martijn.martijn, Unassigned)

References

()

Details

(Keywords: testcase)

To reproduce:
- Drag-drop some text into the input
- Focus the text input, and press ctrl-z or click on "undo" in the context menu

Expected result:
The iframe should disappear

Actual result:
The iframe doesn't disappear.

In a debug build I see this assertion:
###!!! ASSERTION: Invalid batch count!: 'mUpdateBatchCnt >= 0', file c:/mozilla/
mozilla/view/src/nsViewManager.cpp, line 2103

I know of some code in editor that suspends drawing when something is scrolled, that might the cause of this assertion and the cause of this bug.
WFM on 1.9.2 and trunk.  Note that bug 522787 made oninput happen directly
on drop, that's not what fixed this bug though, I have a 1.9.2 build
from around 2009-10-20 where the testcase also works. (all on Windows XP)
WFM, local debug build on Linux x86-64.

-> WORKSFORME
Status: NEW → RESOLVED
Closed: 12 years ago
Flags: in-testsuite?
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.