Bugs linked to a testcase (in test run) are reopened if bug is on RESOLVED FIXED and test run is FAILED while they are in this status

RESOLVED FIXED

Status

RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: daveycoleman, Assigned: gregaryh)

Tracking

x86
Windows XP

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; InfoPath.2)
Build Identifier: 1.1.2

Steps to Repro:
1. I have a test case linked into a test run. I have attached bugs to this test case. 
2. the bugs are on RESOLVED FIXED in Bugzilla.
3. The test case is now put to BLOCKED status.
4. If I click on BLOCKED a second time (by mistake) the bugs are moved to REOPENED FIXED.

Reproducible: Always

Actual Results:  
the bugs were reopened after selecting BLOCKED a second time when the bugs were RESOLVED FIXED.

Expected Results:  
the bugs status should not be moved to REOPENED!
(Reporter)

Updated

12 years ago
Version: unspecified → 1.1
(Reporter)

Comment 1

12 years ago
sorry, that should FAILED instead of BLOCKED. FAILED was hit the second time and the 4 bugs were REOPENED.
(Reporter)

Comment 2

12 years ago
FURTHER INFO:
also happening on Testopia 1.2. have a test server setup with the install on it. have not upgraded my Testopia 1.1.2 yet.

scenario that is causing this:
1. a bug has been RESOLVED FIXED before a testcase's run has been finished.
2. I now moved the testcase run to any status, e.g. FAILED, BLOCKED, PASSED, etc.
3. the bugs are REOPENED that are linked to this test run for this particular testcase.
(Reporter)

Updated

12 years ago
Summary: Bugs linked to a testcase (in test run) are reopened if BLOCKED button is pressed twice → Bugs linked to a testcase (in test run) are reopened if bug is on RESOLVED FIXED and test run has not yet finished.
(Reporter)

Updated

12 years ago
Version: 1.1 → 1.2
(Assignee)

Comment 3

12 years ago
as of Testopia 1.2 you now need to check the "update bugs" box in the case-run to have it update the bugs.

With this box checked, bugs that are RESOLVED will be moved to the REOPENED state only if the test case is marked FAILED. If it is marked PASSED, it will mark the bug VERIFIED.

I am not able to reproduce what you are describing. Are you sure you didn't ckick PASSED after FAILED? If you did, it would have reopened the bug first. This should only happen if you click the "update bugs" check box though. Is this not the case?
(Reporter)

Comment 4

12 years ago
hey Greg,
1.1.2. - this is not an option in 1.1.2 so by default it REOPENS bugs that are fixed(VERIFIED if test run passes) if the test run fails for that testcase. thats fine. its a feature. BUT...

*** BUG ***
1.2 - the "Update Bug Status" checkbox has been made available. this is not working on IE7. Testopia is changing the status of the RESOLVED bug to either REOPENED(if test run fails) or VERIFIED(if test passes) if the "Update Bug Status" is checked or unchecked.
************

sorry if i have deviated from the original problem. looks like the new feature in 1.2 has a bug.

But what i am trying to do is explained in the following scenario.
SCENARIO: I have 8 bugs logged for a test case in build 123. 8 bugs are RESOLVED FIXED while i am still working on build 123. I fail the test because i have not yet received a new build with the new fixes in it. This reopens all 8 bugs again, so the developer is fuming, "Why did you reopen these? they are fixed in the next build"
I hope you understand where i am coming from.

dave
(Reporter)

Updated

12 years ago
Summary: Bugs linked to a testcase (in test run) are reopened if bug is on RESOLVED FIXED and test run has not yet finished. → Bugs linked to a testcase (in test run) are reopened if bug is on RESOLVED FIXED and test run is FAILED while they are in this status
(Assignee)

Comment 5

12 years ago
(In reply to comment #4)
> *** BUG ***
> 1.2 - the "Update Bug Status" checkbox has been made available. this is not
> working on IE7. Testopia is changing the status of the RESOLVED bug to either
> REOPENED(if test run fails) or VERIFIED(if test passes) if the "Update Bug
> Status" is checked or unchecked.
> ************

I am not able to reproduce this in IE7 or IE6. This is what I do:

1. Open a run
2. Attach a closed bug to a test case on that run
3. Click FAILED without checking the "Update Bugs" box

The case is marked failed but the bug remains closed. If I repeat the steps and check the update bugs it does reopen it as expected. 

> SCENARIO: I have 8 bugs logged for a test case in build 123. 8 bugs are
> RESOLVED FIXED while i am still working on build 123. I fail the test because i
> have not yet received a new build with the new fixes in it. This reopens all 8
> bugs again, so the developer is fuming, "Why did you reopen these? they are
> fixed in the next build"
> I hope you understand where i am coming from.
> 
This was why we added the checkbox in the first place. ;-)

On your test system can you try the steps above and see if it is still behaving badly? Also try it in Firefox just to rule out any javascript issues.
Thanks
(Reporter)

Comment 6

12 years ago
Hi Greg,
I am still using version 1.1.3 (am having problems using Cygwin on Windows to update! thats another story!) and have been able to repro the problem in IE7 and Firefox 2.0.

Again: have test run on RUNNING. a linked bug is RESOLVED FIXED. when i move the test run to FAILED, the bug is REOPENED.
The bug shouldn't reopen as it will be rechecked in the next test pass. 
This is wrecking havoc with my Bugzilla Reopened bug count so I have to manually change the bug_activity entries to show the "real" reopened bugs.

As for the 1.2 issue, I will look at this when i get a full upgrade to work properly.

cheers,
dave
(Reporter)

Comment 7

12 years ago
fixed in 1.2.1 build. closing.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.