bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

XMLHttpTransport.watchInFlight Error: [object Error] errors occurs when testcase status is updated in test run

RESOLVED FIXED

Status

Testopia
Test Runs
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: David Coleman, Assigned: Greg Hendricks)

Tracking

x86
Windows XP

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; InfoPath.2)
Build Identifier: 1.2

go to a test run where you have linked test cases for this build.
change the status of the test case to "Running", or any status for that matter.

A popup error occurs which says:
XMLHttpTransport.watchInFlight Error: [object Error]

Press OK but the "Please Wait..." waits on the page. 
A refresh of the page and its OK. looks like it is Dojo related.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

11 years ago
I have upgraded a test system from 1.1.2 to 1.2 and this is where the problem occurred.
working on Windows 2003 Server, MySQL 5, Apache WebServer and bugzilla 2.22.2
(Reporter)

Comment 2

11 years ago
MORE INFO: 
working fine on Firefox 2.0/Windows XP. problem would seem to be IE7 related only.
(Reporter)

Updated

11 years ago
Version: unspecified → 1.2

Comment 3

11 years ago
Same here: IE7 has this error, Firefox 1.6x does not.
(Assignee)

Comment 4

11 years ago
This is due to the way IE handles tables. I just learned what is causing the problem but IE, of course, has to do things their own way. 

It will require a complete redesign of the run page to get this fixed. For now, use Firefox.
Status: NEW → ASSIGNED

Updated

11 years ago
Duplicate of this bug: 397500

Comment 6

11 years ago
It works on Firefox 2.0.0.7.

IE related.

Comment 7

11 years ago
Reproduced on IE6 as well. Unfortunately this is blocking for our Testopia implementation. 

Comment 8

11 years ago
(In reply to comment #7)
> Reproduced on IE6 as well. Unfortunately this is blocking for our Testopia
> implementation. 

Dumb question, perhaps: why not use Firefox?

Comment 9

11 years ago
It's in a corporate environment where IE is the only browser allowed. Which is probably true in a lot of corporate environments that have Microsoft only infrastructures (not that I think that is a good idea but unfortunately that's out of my control). 

Comment 10

11 years ago
Sigh.

Updated

11 years ago
Duplicate of this bug: 406091
(Assignee)

Comment 12

10 years ago
Fixed in 2.0
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.