Closed Bug 376577 Opened 13 years ago Closed 13 years ago

<input type="button" disabled> not rendered as disabled Aqua widget

Categories

(Core :: Widget: Cocoa, defect)

PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: alqahira, Assigned: stuart.morgan+bugzilla)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

Since the Cocoa widget rewrite, disabled <input type="button"> widgets have been drawn as gfx widgets instead of Aqua ones.

The testcase and screenshots in bug 376576 have an example.
Actually, all buttons (type="button", type="submit", type="reset") are affected.
Flags: blocking1.9+
Attached patch fixSplinter Review
The nsNativeTheme border defaults are out of sync with forms.css, so IsWidgetStyled was coming back yes even for unstyled buttons. Enabled buttons only worked because threedface and buttonface happen to be the same color in the Mac look and feel code.
Assignee: joshmoz → stuart.morgan
Status: NEW → ASSIGNED
Attachment #262345 - Flags: review?(joshmoz)
Comment on attachment 262345 [details] [diff] [review]
fix

Looks good, thanks! Can you please add a comment on checkin about the need to keep those values in sync with forms.css? There is a bug about getting rid of that dependency (bug 240117) but it seems that won't get fixed for gecko1.9.
Attachment #262345 - Flags: review?(joshmoz) → review+
Attachment #262345 - Flags: superreview?(vladimir)
Attachment #262345 - Flags: superreview?(vladimir) → superreview?(dbaron)
Comment on attachment 262345 [details] [diff] [review]
fix

sr=dbaron (although it seems broken that we use "outset ButtonFace" rather than using ButtonHighlight and ButtonShadow; is there a bug on that?)
Attachment #262345 - Flags: superreview?(dbaron) → superreview+
landed on trunk, though I didn't add my comment. will do that soon.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.