3 modes needed in Address Editing!

RESOLVED DUPLICATE of bug 392932

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED DUPLICATE of bug 392932
11 years ago
8 years ago

People

(Reporter: durumdara, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; hu; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: version 2.0.0.0pre (20070403)

Now TDB I can edit or paste email addresses in two mode:
- use first editbox, write an address, use enter, and paste/write new
- use first editbox, write/paste all addresses to in it

It is very good in some cases, but hateable in others.

The third mode needed I think. In this mode all of the addresses are merged by type (cc, bcc, and so on), and one editbox used to edit for every type of mail addresses.

Example - normal way:
to: jano@budapest.hu
to: noe@israel.org
cc: ali@bagdad.ir
bcc: johann@nurnber.de
bcc: kalima@india.com

Showed as:
to: jano@budapest.hu, noe@israel.org
cc: ali@bagdad.ir
bcc: johann@nurnber.de, kalima@india.com

First good thing: 
This mode I simply change my types with copy-paste. 
If I use addr. groups, and I wrote an email the use 100 men with "to", but later I need to change them to "bcc", I need to change every of them one-by-one.
But in this mode I can copypaste them, as in Google Mail.

Second good thing:
This mode is makes easy to implement a trick I call "Extract address groups I used in mail".
Many times I got mails what I want to forward, but the sender is a member in my dest. group.
So: I need to decide what I do. 1.) Send it simply. In this way the sender is got his/her mail back. 2.) I copypaste all of the group members except this one.
3.) I Send Later the mail, open it, and remove this member.

But in this editing mode I can use (recursive) extraction (because of group in group), and tdb is sorted the addresses to editboxes in way that aviod multiple addresses.

Third good thing:
I can simply rejoin my addresses after the tdb splitted (separated) them.
Example: I need to send many mails with Gmail Web, but my addresses are in a group. I open a new mail, paste and extract the group, and simply recopy it to gmail.






Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

10 years ago
Related to/duplicate of bug 395606 -> bug 392932?

Updated

10 years ago
Assignee: mscott → nobody

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392932
You need to log in before you can comment on or make changes to this bug.