Upgrade from 1.1.3 to 1.2 -Error when accessing the Builds and Environments pages - Undefined subroutine &Bugzilla::Testopia::Environment::Param called at Bugzilla/Testopia/Environment.pm line 680.

RESOLVED INVALID

Status

Testopia
Environments
--
major
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: David Coleman, Assigned: Greg Hendricks)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; InfoPath.2)
Build Identifier: 1.2

I have updated Testopia 1.1.2 to 1.2 on a test server (windows 2003 server, MySQL, Apache, IE7). I had 2 test runs, 2 test cases, 1 test plan, 2 builds and 1 environments setup previously.
When i go to the Environments page and the Builds pages I am getting errors.

Reproducible: Always

Steps to Reproduce:
1. go to create a new test run.
2. go to select an environment but there is nothing in the dropdown even though i used an environment when creating test runs in 1.1.2
3. go to create a new environment by pressing the "Environments" hyperlink.
4. brought to http://<serverName>:8080/tr_list_environments.cgi?product_id=2
Actual Results:  
but am given an error:
undef error - Undefined subroutine &Bugzilla::Testopia::Environment::Param called at Bugzilla/Testopia/Environment.pm line 680.

the "Builds" page is also giving an error which looks related.

Can't locate object method "canedit" via package "Bugzilla::Testopia::Product" at C:/Program Files/Apache Software Foundation/Apache2.2/htdocs/bugzilla/tr_builds.cgi line 51.


Expected Results:  
that both pages work ok

this is the line where the error is pointing to:
return 0 unless $self->canedit && Param("allow-test-deletion");
(Reporter)

Updated

11 years ago
Summary: Upgrade from 1.1.2 to 1.2 -Error when accessing the Builds and Environments pages - Undefined subroutine &Bugzilla::Testopia::Environment::Param called at Bugzilla/Testopia/Environment.pm line 680. → Upgrade from 1.1.3 to 1.2 -Error when accessing the Builds and Environments pages - Undefined subroutine &Bugzilla::Testopia::Environment::Param called at Bugzilla/Testopia/Environment.pm line 680.
(Assignee)

Comment 1

11 years ago
I am not able to reproduce this using IE or Firefox. 

It appears as though your Testopia files were not properly updated as the line that you mention no longer exists in 1.2. How did you upgrade? 

You may want to consider using the cvs_update script to update to the current tip. It is a bash script however which means you would have to run it in cygwin on windows. You can find it in the testopia/scripts directory.
(Reporter)

Comment 2

11 years ago
ok Greg, i will look into it.
I copied over the files manually from the archive, updated the bugzilla files manually by going through the patch file, ran the tr_install.pl -nopatch command and then checksetup.pl.
(Reporter)

Comment 3

11 years ago
upgraded to 1.2 again and it didn't happen. invalid bug.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.