Opens JHTML file vs. Displaying Actual Web Page

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: jordan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME - 05/03, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

When going to the website historybookclub.com, Firefox fails to open the page, but instead opens the Index.JHTML file from the web site giving me the option to open it with a specific application or save it to disk.

Reproducible: Always

Steps to Reproduce:
1.Type www.historybookclub.com into site field
2.Hit Enter/Return
3.See the open/download dialog
Actual Results:  
See the Dialog "Opening index.jhtml" 

You have chosen to open index.jhtmlwhich is a JHTML file from http://www.historybookclub.com

What should Firefox do with this file?

Open?
Save to Disk?

Expected Results:  
See the front page to www.historybookclub.com
This works for me using Firefox 2.0.0.3 on Mac OS X and Windows XP.

Please try this with a new profile. http://kb.mozillazine.org/Profile_Manager
Also wfm with a current SeaMonkey trunk build.
Reporter: Is this still a issue, did you try what Samuel suggested in Comment 1?
Whiteboard: CLOSEME - 05/03
Closing as WFM based on comment 1 and 2. If you can reproduce using Firefox 2.0.0.3 or later or using SeaMonkey 1.1.1 or later, please comment to that affect and reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.