implement message filter cloning / copying / duplicating

RESOLVED DUPLICATE of bug 214548

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 214548
11 years ago
11 years ago

People

(Reporter: Sy Ali, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2) Gecko/20070228 PCLinuxOS/2.0.0.2-1pclos2007 (2007) Firefox/2.0.0.2
Build Identifier: version 1.5.0.9 (20070117)

This doesn't seem like a new idea to me, but it's inconvenient to use the UI to copy from one filter to the next.  I can't open two message filter dialogues (of course) to make it easy.

Delving into textfiles works, but most regular users won't think of that.

So the feature would create a 'clone' or 'copy' or 'duplicate' button on the right.  It would copy the currently-selected item underneath the currently-selected item, with the name changed to "name (copy)" or "name (copy-1)" etc if there is a name conflict.

This may be related to Bug 229493 - Need a way to move/copy filters from one account to another.

Reproducible: Always

Comment 1

11 years ago
I need this also ...
This bug is a dupe of bug 214548 in Core, which is global for TB et SeaMonkey
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 214548
You need to log in before you can comment on or make changes to this bug.