Redirect to another URL works in Firefox but not Camino

VERIFIED INVALID

Status

VERIFIED INVALID
12 years ago
12 years ago

People

(Reporter: terryl, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.10) Gecko/20070228 Camino/1.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.10) Gecko/20070228 Camino/1.0.4

http://www.weather.com/weather/local/USNV0049?from=recentsearch
is supposed to redirect to
http://www.weather.com/outlook/travel/businesstraveler/local/USNV0049?from=recentsearch
as it does in firefox.  Resulting page is incorrect.

Reproducible: Always

Steps to Reproduce:
1. Logged into weather.com
2. click on saved location or just go directly to http://www.weather.com/weather/local/USNV0049?from=recentsearch
3.
Actual Results:  
screwed up page show

Expected Results:  
redirect to http://www.weather.com/outlook/travel/businesstraveler/local/USNV0049?from=recentsearch

and shows good page
I see no indication that the first link you gave is supposed to redirect. In Firefox, it doesn't. In Camino, it doesn't. In Safari, it doesn't. Can you please try this again using Firefox 2.0.0.3 and a recent Camino nightly (from caminobrowser.org/development)? I can't reproduce at all.
(Reporter)

Comment 2

12 years ago
Okay, I figured out it's probably redirecting on some cookie that was set in firefox, and the messed up page is a bug in weather.com when you sign on with a new browser without the cookie.  Sorry for the trouble.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
No problem, thanks for reporting back.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.