If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

SeaMonkey Mail crashes frequently [@ JS_strtod] if WXKbd is running

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
critical
RESOLVED WORKSFORME
11 years ago
4 years ago

People

(Reporter: Chris Ross, Unassigned)

Tracking

({crash, stackwanted})

SeaMonkey 1.1 Branch
x86
Windows XP
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.8.1.2) Gecko/20070222 SeaMonkey/1.1.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.8.1.2) Gecko/20070222 SeaMonkey/1.1.1

SeaMonkey crashes frequently (5 - 25 times a day) with many message
operations (e.g. deleting a message, downloading the rest of a long message that had been limited (to 10kB) by the 'Disk Space' option; trying to modify an unsent message; even sometimes just opening a message to read...).

If a message is dragged to the Trash (instead of deleting it with <Delete> or right-click -> Delete) it doesn't happen.
When the program is restarted after the crash the requested operation has been carried out.

The error message is always the same:

--------
seamonkey.exe - Erreur d'application
---------------------------
L'exception Opération en virgule flottante non valide.
(0xc0000090) s'est produite dans l'application à l'emplacement 0x60e62cfb.
--------

(That means "invalid floating point operation" xxxx at yyyy)

The error occurs in 'JS3250.dll':
"Unhandled exception in seamonkey.exe (JS3250.DLL): 0xC0000090: Float
Invalid Operation."

Here is the code just before the crash point:

60E62CDA   push        ebx
60E62CDB   push        esi
60E62CDC   push        edi
60E62CDD   push        436h
60E62CE2   call        dword ptr ds:[60EAE060h]
60E62CE8   mov         esi,eax
60E62CEA   xor         edx,edx
60E62CEC   cmp         esi,edx
60E62CEE   pop         ecx
60E62CEF   mov         dword ptr [ebp-2Ch],esi
60E62CF2   je          60E630F2
60E62CF8   fld         qword ptr [ebp+0Ch]
-> 60E62CFB   fcomp       qword ptr ds:[60EAE118h]

However when I get into the Visual C++ debugger the current instruction pointer is at 60eb094b:

60E60939   test        eax,eax
60E6093B   jne         60E60928
60E6093D   pop         edi
60E6093E   pop         esi
60E6093F   ret
60E60940   push        ebp
60E60941   mov         ebp,esp
60E60943   sub         esp,54h
60E60946   mov         ecx,dword ptr [ebp+10h]
60E60949   xor         eax,eax
-> 60E6094B   fldz


Reproducible: Sometimes

Steps to Reproduce:
1. restart computer
2. launch SeaMonkey Mail
3. select a message and delete it (without doing anything else before)
Actual Results:  
Abnormal program termination (immediate)

Expected Results:  
Continue normal operation

My version of SeaMonkey 1.1.1 is the French localised build.
This never happened with Mozilla (1.7.12 was my last version)
(Reporter)

Updated

11 years ago
Version: unspecified → SeaMonkey 1.1 Branch

Comment 1

11 years ago
Do you have a Talkback ID or an actual stacktrace for the crash? http://kb.mozillazine.org/Talkback
Keywords: crash, stackwanted
(Reporter)

Comment 2

11 years ago
Sorry, no.  My installer doesn't offer the possibility of installing TalkBack - I just ran it again to be quite sure of this. (It is the French localised version 1.1.1.2007022206.)
I have looked for a way to install it separately but couldn't find it - is this possible?
(Reporter)

Comment 3

11 years ago
I thought I would try the en-US installer
 (1) to be able to use Talkback
 (2) to see if the same problem occurred.

1. that installer didn't offer me Talkback either
2. yes, the crashes occur in the same circumstances
 - so it _isn't_ unique to the French localised build.
 (but I wonder if there is any connection with the French version of XP).

It is now 100% reproducible as described above (no need to restart the
computer, just delete a message as the very first thing after starting
Seamonkey.)

Comment 4

11 years ago
do you have allchars or something? (bug 334263)
Whiteboard: DUPEME
(Reporter)

Comment 5

11 years ago
OK - well done, I think you've got it (subject to confirmation).

I don't have AllChars - I have a French keyboard (and the only Mozilla extension I have is EnigMail).
But I do have another keyboard macro generator - WXKbd. And if I turn it off the problem seems to go away.
I will test this more extensively tomorrow (it's evening here now) and also try out AllChars (which I didn't know before). I will also contact the author of WXKbd for information about his language/compiler.

Thanks to all: I will keep you informed.

Comment 6

11 years ago
optimistically changing summary.
Summary: SeaMonkey Mail crashes frequently → SeaMonkey Mail crashes frequently [@ JS_strtod] if WXKbd is running
(Reporter)

Comment 7

11 years ago
I have contacted the author of WXKbd and am awaiting his response.
Looking at the .exe in hexa I found that his programme is also written in
Borland Delphi...
(Reporter)

Comment 8

11 years ago
OK, this morning without WXKbd a fair number of tests without a single crash.
If I start it again the crashes begin again immediately.
So I consider that is the cause.

Sorry for blaming SeaMonkey, but I have used WXKbd with Mozilla for years without any problems and it would never have occurred to me to try that.
I'd still like to know what's changed and why this incompatibility?

PS - I have installed AllChars v.3.6.3 and it doesn't upset SeaMonkey.

Thanks to all
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 9

11 years ago
Nothing broken or fixed in the SeaMonkey code itself.
Resolution: FIXED → WORKSFORME
Crash Signature: [@ JS_strtod]

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.