As of 2.0.0.2 animated gifs quit replaying when the reload button was clicked

RESOLVED DUPLICATE of bug 129986

Status

()

defect
--
minor
RESOLVED DUPLICATE of bug 129986
12 years ago
12 years ago

People

(Reporter: unclespongehead, Unassigned)

Tracking

({qawanted, regression})

1.8 Branch
PowerPC
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

There is an example at http://home.comcast.net/~unclespongehead.  The animated gif plays once by design.  In 2.0.0.1 and other browsers the animation will replay when the page is reloaded.  2.0.0.2 and 2.0.0.3 no longer replay the animation.

image.animation_mode is set to the default value of normal.



Reproducible: Always

Steps to Reproduce:
1. wait for animation to complete 1 time (there are 8 frames)
2. hit the reload button
Actual Results:  
The animation does not play in the Mac or PC versions, 2.0.0.2 and 2.0.0.3

Expected Results:  
The animation should replay as in 2.0.0.1 and other browsers.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070406 Minefield/3.0a4pre
I don't see it as a (recent) regression (in Windows) for I could reproduce the problem in all versions from 1.0.x. It needs a shift+reload.
Opera and IE replay the animation with only reload.

Comment 3

12 years ago
This *might* be a regression from bug 347852, but that is just a guess. We're going to need someone who has a Mac to look into this.
Severity: normal → minor
Component: General → Networking: Cache
Keywords: qawanted, regression
Product: Firefox → Core
QA Contact: general → networking.cache
Version: unspecified → 1.8 Branch
Using Firefox 2.0.0.1 on Mac OS X 10.4.9, I don't see the animated gif reply on refresh. I can only get it to reply on hard refresh. Are you sure this worked in 2.0.0.1 for you? Can you please try 2.0.0.1 again with a new profile? 

http://kb.mozillazine.org/Profile_Manager
Reporter

Comment 5

12 years ago
I am very sorry.  Sam is correct, the problem existed prior to 2.0.0.2.  I just tried 2.0 and 2.0.0.1 to confirm it.  I swear it used to work.  Like you guys haven't heard that before.

The problem occurs on both the Mac and Windows versions of Firefox.  Shift+reload works as Ria pointed out.  I assume that's what Sam means by hard reset.

I thought I had discovered a newly created error, which is why I reported it.  Sorry for jumping the gun.

If there is a desire to pursue this let me add a scenero that may help somebody:

1. Close all windows
2. Open new window
3. Go to http://home.comcast.net/~unclespongehead/BoardmanAnimated.html, animation plays
4. Open new window/tab
5. Go to http://home.comcast.net/~unclespongehead/BoardmanAnimated.html, animation DOES NOT play

If you close the previous window first, the animation plays.
Sounds like you're seeing the same as me then, so I'm duping to the older bug.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 129986
You need to log in before you can comment on or make changes to this bug.