bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

anonymous html:img doesn't show on FF2

RESOLVED WONTFIX

Status

()

Core
XBL
RESOLVED WONTFIX
11 years ago
11 years ago

People

(Reporter: aaronr, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.82 KB, application/xhtml+xml
Details
(Reporter)

Description

11 years ago
Created attachment 260919 [details]
testcase

If I have an html:img as my anonymous content and set the src attr during construction, the image doesn't show.  However, if I set the src attr of a non-anonymous image using JS, it works.  This bug appears on FF2.x and FF1.5.x.  Bug does not appear on trunk.

Any chance of getting this fixed on the 1.8 branch at least?  It is blocking an xforms feature.
Unfortunately I doubt a fix would match any of the criterias we have for branch patches. Is this a regression by any chance?

If so, please attach a simple testcase
This got fixed on trunk by the fix for bug 11011.  That bug is in the "no way it lands on branch" category.

The real issue, probably, is that on branch XBL constructors run at an unsafe time.  Touching the DOM from them is:

1)  Not safe (can crash).
2)  May not work right.

Simply putting the src set off on a timeout should make things work.
Oh, and your other option given that testcase is to use xbl:inherits.  Not sure whether that's an option with your real use case.
(Reporter)

Comment 4

11 years ago
(In reply to comment #2)
> This got fixed on trunk by the fix for bug 11011.  That bug is in the "no way
> it lands on branch" category.
> 
> The real issue, probably, is that on branch XBL constructors run at an unsafe
> time.  Touching the DOM from them is:
> 
> 1)  Not safe (can crash).
> 2)  May not work right.
> 
> Simply putting the src set off on a timeout should make things work.
> 

using the timeout worked like a charm.  Thanks for the quick feedback!  Resolving bug as WONTFIX per comment #2
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.