Closed Bug 376832 Opened 14 years ago Closed 14 years ago

"L0, 1 of 1" being exposed for acc_description on everything

Categories

(Core :: Disability Access APIs, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: aaronlev, Assigned: surkov)

References

(Blocks 1 open bug)

Details

(Keywords: access, regression)

Attachments

(1 file, 1 obsolete file)

- The get_accDescription() hack is 1-based for everything. 
- If something doesn't have a relevant level, it should either affect the description, or if a group, just say "n of m"
- If something does have a relevant level it should be at least L1
I think GroupPosition() needs a way of stating "not relevant" for each item so that get_accDescription() knows what to do. Right now the value of 0 is being used as not-relevant, but some of the indices are 0-based (unfortunately).

I'm seeking clarification from Pete Brunet on what to do in IA2::groupPosition() to show that a value is not relevant (used).
Pete Brunet is going to change the comments in IAccessible2.idl so that everything is 1-based, and 0 means not relevant.

Can you change our IDL and code to do the same? We don't need to wait for Pete's new IDL because it's just a comment change.
Attached patch patch (obsolete) — Splinter Review
Attachment #261662 - Flags: review?(aaronleventhal)
Attached patch patch2Splinter Review
Attachment #261662 - Attachment is obsolete: true
Attachment #261663 - Flags: review?(aaronleventhal)
Attachment #261662 - Flags: review?(aaronleventhal)
Comment on attachment 261663 [details] [diff] [review]
patch2

Thanks, I think you need to change a comment in nsIAccessible.idl to say everything is 1-based.
http://www.microsoft.com/downloads/details.aspx?familyid=4179742F-1F3D-4115-A8BA-2F7A6022B533&displaylang=en

Also you might want to make your checks >0 instead of != 0, just to be safe that we don't accidentally use any negative numbers. Could assert that as well, or, it's probably better just change the IDL to use unsigned longs.
Attachment #261663 - Flags: review?(aaronleventhal) → review+
(In reply to comment #5)
> (From update of attachment 261663 [details] [diff] [review])
> Thanks, I think you need to change a comment in nsIAccessible.idl to say
> everything is 1-based.
> http://www.microsoft.com/downloads/details.aspx?familyid=4179742F-1F3D-4115-A8BA-2F7A6022B533&displaylang=en
> 
> Also you might want to make your checks >0 instead of != 0, just to be safe
> that we don't accidentally use any negative numbers.

Fixed, checked in.

 Could assert that as well,
> or, it's probably better just change the IDL to use unsigned longs.
> 

Agree, should IA2 be changed firstly?
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You can just change our interface right away, because we know it's correct.
You need to log in before you can comment on or make changes to this bug.