Update verification workaround for duplicate all-l10n.js in Thunderbird2 windows installer

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
11 years ago
5 years ago

People

(Reporter: nthomas, Assigned: nthomas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
Created attachment 260974 [details] [diff] [review]
Fix unpack order

See 376877 for the details, but the short version is that two all-l10n.js are included in the windows installer for Thunderbird. On applying the complete update the diff between old and new "install" directories reports:

< //@line 36 "/cygdrive/c/builds/tinderbox/Tb-Mozilla1.8-l10n-Release/WINNT_5.2_Depend/mozilla/../l10n/ca/mail/all-l10n.js"
< 
< //@line 38 "/cygdrive/c/builds/tinderbox/Tb-Mozilla1.8-l10n-Release/WINNT_5.2_Depend/mozilla/../l10n/ca/mail/all-l10n.js"
< 
< pref("general.useragent.locale", "ca");
---
> //@line 36 "/cygdrive/e/builds/tinderbox/Tb-Mozilla1.8-Release/WINNT_5.0_Depend/mozilla/mail/locales/en-US/all-l10n.js"
> 
> //@line 38 "/cygdrive/e/builds/tinderbox/Tb-Mozilla1.8-Release/WINNT_5.0_Depend/mozilla/mail/locales/en-US/all-l10n.js"
> 
> pref("general.useragent.locale", "en-US");
> pref("spellchecker.dictionary", "en-US");

Which is erroneous because the same is not true when you try to reproduce this using the app itself (forcing a complete update).

It turns out the update verification script (unpack.sh) does a 

  7z x <installer>
  cp -rp localized/* nonlocalized/* optional/* bin/

to simulate an install. This patch explicitly sets the order of copy for the localized and nonlocalized dirs, and avoids any confusion by doing the operations sequentially.
Attachment #260974 - Flags: review?(rhelmer)
Attachment #260974 - Flags: review?(rhelmer) → review+
(Assignee)

Comment 1

11 years ago
Checked in.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.