Not-well-formed XML causes Live Bookmarks to not load the RSS feed

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: Sander v Z, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

When I discoverd the problem it was about the URL http://feeds.nos.nl/nosnieuws, in de meantime it is fixed but I saved the actual RSS feed as XML file, so i could report it.

The bug is in the Live Bookmarks.

The RSS feed is attatched to this bugreport

As you can see in the pre-last item there are a few strange symbols in the discripton. These symbols cause the error.

Using a file with the XML code above regenerates the error 'Could not load feed...'

Reproducible: Always

Steps to Reproduce:
1. Save the errorous XML code on your local disk, or on a server
2. Add a new Live Bookmark, use the local disk file as URL, or enter the URL from the server where you saved it (use file://LOCALpath when you stored it local)
3. Try to open the just created live bookmark. It says 'Could not load feed'
Actual Results:  
Instead of the items from the RSS feed it says 'Could not load feed'.

Expected Results:  
Normal RSS values, as with any other live bookmark

Render the RSS feed properly
(Reporter)

Comment 1

11 years ago
Created attachment 261056 [details]
Errorous RSS feed

The RSS code when the problem occured
That's not XML - the XML spec makes it very clear that "A data object is an XML document if it is well-formed [...]" and including 0x1E makes that file not well-formed. While there are RSS readers that make heroic efforts to turn things which are not XML into XML, or which simply give up on XML and and implement their own non-XML parsers, Firefox's Live Bookmarks is not one, because encouraging a feed ecosystem where all someone needs to to parse RSS is an XML parser is much more in keeping with its mission than encouraging an ecosystem where anyone who wants to parse feeds needs to know how to correct a thousand different sorts of not-well-formedness with the same unstandardized and unpublished sort of error correction that the reader the feed producer "tested" with uses.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Summary: Strange symbols cause FireFox to not propperly load the RSS feed → Not-well-formed XML causes Live Bookmarks to not load the RSS feed
Duplicate of this bug: 462689
You need to log in before you can comment on or make changes to this bug.