If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Embedded YouTube flash videos do not allow tab switching

RESOLVED INVALID

Status

()

Firefox
Tabbed Browser
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: krazy karl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 ImageShackToolbar/3.0.4 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 ImageShackToolbar/3.0.4 Firefox/2.0.0.3

When a YouTube video is embedded in a page using YouTubes Embed code, trying to switch to a different tab by clicking on it does not work. This only happens while the video is playing. It does not effect keyboard shortcuts to change tabs, only directly clicking on them. If a tab has been clicked on while the video is playing, and then the video is paused, the tab come to focus. Any animated GIF images also seem to "pause" while the YouTube video is playing, and then resume while the video is paused. I have created a new profile to confirm no Add-ons are causing this. Thank you ahead of time for any help.

Reproducible: Always

Steps to Reproduce:
1. view a page with an embedded YouTube video
2. play the video
3. click a tab, nothing happens
4. pause the video
5. the tab comes to focus
Actual Results:  
1. the tab comes to focus

Expected Results:  
focused the tab without the video being paused

I have created a new profile to confirm no Add-ons are causing this.
This particular case works for me in Firefox 2.0.0.3 under Windows but it takes some time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 355818

Comment 2

11 years ago
Could you post your flash version? (see in about:plugins)

Perhaps try updating your flash to see if it solve the problem.
(Reporter)

Comment 3

11 years ago
Shockwave Flash

    File name: NPSWF32.dll
    Shockwave Flash 8.0 r22

MIME Type 	Description 	Suffixes 	Enabled
application/x-shockwave-flash 	Macromedia Flash movie 	swf 	Yes
application/futuresplash 	FutureSplash movie 	spl 	Yes
(Reporter)

Updated

11 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

11 years ago
This really seems like a duplicate of bug 355818.

Could you try updating to Flash 9?
(Reporter)

Comment 5

11 years ago
I will try that
Ria, François, do you see this...?  ... combinations of pause and play break keys ctrl+T and ctrl+L (both branch and trunk) ... and ctrl+pgdn tab navigation also breaks when it hits the flash's tab (which rings like a dupe to me)

the similarity to bug 379530 is amazing. however, while I can recreate 379530, I cannot recreate this bug nor do I see delays as mentioned in comment 1 with Karl's URL with flash 9. 

WFM using: 
branch Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
trunk Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a4pre) Gecko/20070427 Minefield/3.0a4pre
Summary: Embedded YouTube videos do not allow tab switching → Embedded YouTube flash videos do not allow tab switching
p.s. Karl doesn't appear to be getting mail when this bug is updated.
please reopen if you can recreate this using newest version of flash 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.