Error message when trying to drag a mail attachment to the desktop.

RESOLVED DUPLICATE of bug 203307

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 203307
11 years ago
11 years ago

People

(Reporter: Joshua Gordon, Assigned: Scott MacGregor)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 1.5.0.10

I have the preview pane visible at all times so that if I have an email message with an attachment, I can see it at the bottom of my preview pane window. I am using an IMAP account.

If I have an attachment of considerable size (say over 800-900kb) and I try to drag it to the desktop, I often get an error message that says "Error Moving File or Folder: Cannot move file: Cannot read from the source file or disk".

This seems to happen if the attachment is somehow trying to download in the background but I don't always get the download window. Instead I get this error message. As a workaround I simply have to right click on the attachment, and do a Save As...

It seems to me that there's some kind of issue here when during a drag and drop of a file attachment to a folder (or desktop) when using IMAP that Thunderbird doesn't initiate the transfer. Instead, and because the file doesn't exist (because it hasn't yet been downloaded), I get the error message.

Reproducible: Sometimes

Steps to Reproduce:
1. Setup an IMAP account
2. Send yourself a decent sized attachment (say around 3 or 4 mb just to be safe)
3. Make sure your preview pane is always on so you can see the attachment(s) listed in the bottom of the message window.
4. Minimize all windows except for thunderbird and make sure the desktop is visible behind the thunderbird window.
5. Highlight the email with the large attachment (you should see the status bar of Thunderbird say "downloading message" or something similar).
6. Click the attachment with the left mouse button and drag it to the desktop.

You SHOULD see the error at this point.
Actual Results:  
I get the error box.

Expected Results:  
I expected the drag and drop to work fine but for large attachments, the download window should just appear, indicating to me that it has to download this large attachment from the server.
confirmed with imap account, works fine on pop3, failed with imap on Thunderbird 2 RC 1. I cannot drag a big attachment to the desktop on imap
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 2.0
(Assignee)

Comment 2

11 years ago
carsten, can you reproduce this on the trunk? I suspect this is a dupe of Bug 203307.
scott, works for me in trunk Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070417 Thunderbird/3.0a1 ID:2007041703 [cairo], so i guess its a dupe. Resolving as dupe
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 203307
You need to log in before you can comment on or make changes to this bug.