Incorrect display of :first-line and :first-letter combined

VERIFIED FIXED

Status

()

Core
CSS Parsing and Computation
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: Jan, Assigned: dbaron)

Tracking

unspecified
PowerPC
Mac OS X
Points:
---
Bug Flags:
blocking1.9 +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a4pre) Gecko/20070402 Minefield/3.0a4pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a4pre) Gecko/2007040204 Minefield/3.0a4pre

first-line and first-letter pseudo classes are displayed incorrectly

Reproducible: Always

Steps to Reproduce:
1. Open a new Browser Window.
2. Open attached web page.
3. The web page is loaded properly.

Actual Results:  
In the second paragraph the first letter is 350% bigger than the rest and
maroon, while the entire first line is normal and black


Expected Results:  
In the second paragraph the first letter is 350% bigger than the rest and
maroon, while the entire first line is 200% bigger than normal and green
(Reporter)

Comment 1

11 years ago
Created attachment 261125 [details]
Test page
(Reporter)

Updated

11 years ago
Is this a trunk regression?  When did it regress?
Flags: blocking1.9?

Comment 3

11 years ago
Hmm, isn't this because the line that is supposed to be 200% bigger and green is not on the same line as the first letter? I can manage to get everything on the same line (and thus display correctly) if I resize the window a bit. Something odd is going on, though - It's almost as the first letter displays as a block element and pushes the rest of the line down in certain window sizes.

Comment 4

11 years ago
Created attachment 261156 [details]
Screenshots - different window sizes

Note the behaviour of the first letter in different window widths.

Comment 5

11 years ago
Forgot to mention this is with a phlox trunk build (seamonkey on toolkit) from yesterday (10.3.9)

Comment 6

11 years ago
No, the test case can work correctly.
The problem is that :first-letter is broken: bug 368912.
Sometimes it displays as a sort of block on it's own line. In that case, the :first-line pseudo-class is not applied to the rest of what is the first line.
Flags: blocking1.9? → blocking1.9+
Summary: Incorrect display of mutli pseudo elements → Incorrect display of :first-line and :first-letter combined
Assignee: nobody → dbaron

Comment 7

11 years ago
I've commented on bug 368912 that it seems to be fixed as of 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070603 Minefield/3.0a6pre

The attached test case on this bug appears to be fixed as well, so whatever fixed that bug may have fixed this one as well.
I think this was fixed by bug 381703.
Reporter, could you test again in the latest nightly if now everything works as you expected?

Comment 9

11 years ago
This was indeed fixed by bug 381703.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Updated

11 years ago
Status: RESOLVED → VERIFIED

Updated

11 years ago
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.