Right and bottom border missing for percentage size iframe inside table

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: martijn.martijn, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

See upcoming testcase, you should see a right and bottom border for the iframe.
This regressed between 2006-01-25 and 2006-01-26, probably a regression from the frame display lists bug, bug 317375.
Posted file testcase
Posted file reference rendering
Component: Layout → Layout: Tables
QA Contact: layout → layout.tables
The IFRAME is overflowing the cell because its content-rect takes 100% width and height and it has a border. The height overflow triggers a special table path that makes us clip the cell contents to the cell rect, so we clip off the right and bottom of the IFRAME. So this is pretty much working as designed. What should our behaviour be? We were doing clipping before in percent-height overflow situations --- I didn't make up this hack :-) --- do you know what we were clipping?
Ah, I see what you're meaning.
Apparently, in the older builds the iframe wasn't clipped for some reason. So actually, things seem to have improved here.
So this is invalid.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
Worth a != test to assert that this behavior is correct, perhaps?
Flags: in-testsuite?
Yeah, but probably it's better to make an == test out of this. I'll try to do that.
You need to log in before you can comment on or make changes to this bug.