Closed Bug 377128 Opened 13 years ago Closed 6 months ago

Formatting with bold option doesn't seem to work for pages with Tamil and Gujarati content.

Categories

(Core :: Graphics, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: qa.naresh, Unassigned)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9a1) Gecko/20061204 GranParadiso/3.0a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9a1) Gecko/20061204 GranParadiso/3.0a1

Formatting with bold option doesn't seem to work for pages with Tamil and Gujarati content. This is observed in Linux>Firefox3 (Gran Paradiso) only, while in Windows>Firefox3 (Gran Paradiso) it looks fine.

 Bold format not seen in pages containing Tamil Text. On Windows>FF3 it looks fine.
   Source: dinamani.com.
   Snapshot: Firefox3_Linux_Tamil_BoldFormattingNotWorking.gif
 

Gujarati: Formatting with Boldness not seen working. (Seen only on Linux>FF3)
   Source: guajaratsamachar.com
   Snapshot: Firefox3_Linux_Gujarati_FormattingNotSetOnContent.gif
 

Reproducible: Always

Steps to Reproduce:
1. Launch the Firefox3>Gran Paradiso browser
2. Load dinamani.com and guajaratsamachar.com in two different tabs.
3. Make sure that the respective ttf fonts (available for download) from the site are installed properly.
4. Click on any of the news headlines.

Actual Results:  
The headers of the news item should be seen in bold.

Expected Results:  
The headers are not seen in bold.
    Attaching snapshots for the same.
3.0a1 is very old, for something being worked on as much as fonts and text are currently. Could you please retest with either 3.0a3, or better yet a current nightly build?
Component: General → GFX: Thebes
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk
This might be a dupe of bug 333126
Depends on: 333126
If the fonts are not have bold/italic style file, comment 4 is a true.
Same behavior with Khmer script rendering, bold style not applied to text.
The fix for bug 327879 should have fixed this.
But I can't confirm as there is something wrong with the encoding at dinamani.com.
Depends on: 327879
dinamani.com uses "x-user-defined" encoding, and requires installing its own font from http://www.dinamani.com/fonts/tmnews.ttf. It looks to me as if it isn't fixed, but it may be a different issue since it doesn't seem to work in Firefox 2 either.

The site has migrated to Unicode.

Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.