Javascript area.search and link.search doesn't work in browser

VERIFIED INVALID

Status

()

VERIFIED INVALID
12 years ago
10 years ago

People

(Reporter: jan.pieniadz, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

16.44 KB, application/x-zip-compressed
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a4pre) Gecko/20070402 Minefield/3.0a4pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a4pre) Gecko/2007040204 Minefield/3.0a4pre

Javascript area.search and link.search doesn't work in browser

Reproducible: Always

Steps to Reproduce:
1. Open attached Test page.
Actual Results:  
?ser=../ should be found by search function.

Expected Results:  
Nothing is found.
(Reporter)

Comment 1

12 years ago
Created attachment 261255 [details]
Test page
(Reporter)

Updated

12 years ago

Comment 2

12 years ago
The reason the testcase fails is because it's invalid. See bug 146788 comment 4 (by jst, who wrote the spec.). It works fine if you have the ?xxx part of the URL before the anchor. 

That said, we should probably get a correct testcase in our DOM testsuite for this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Component: General → DOM: HTML
OS: Mac OS X → All
Hardware: Macintosh → All
Resolution: --- → INVALID
Version: unspecified → Trunk
(Reporter)

Updated

11 years ago
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: general → general
You need to log in before you can comment on or make changes to this bug.