Closed Bug 377301 Opened 15 years ago Closed 14 years ago

New mail notification window displays details on old emails

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 375717

People

(Reporter: edwdig, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: version 2.0.0.0 (20070326)

I'm using an IMAP (SSL) mail account with about 1200 messages in my Inbox. Whenever I get new mail, the notification pops up a summary of about the 20th message in my inbox, along with other messages in that area (disappears too quick for me to distinguish them).

Reproducible: Always

Steps to Reproduce:
1. Set up IMAP account with lots of already read email
2. Download old mail
3. Receive new email
Actual Results:  
Receive notification that you have new email along with a summary of very old email

Expected Results:  
See summary of the new email
Tracked it down closer. It's not actually displaying mail from my inbox. It's displaying mail from another folder. This folder is an old sent mail folder copied from another account. Many of the messages are marked as new in it. This folder is not referenced in any filters or settings, so there's really no reason for Thunderbird to be looking at it.
I'm getting a similar thing, except I use POP (multiple accounts) and not IMAP. For me, the situation goes something like this (when starting from a clean slate):
1) One new spam message arrives. Popup appears and shows details of that one message. I ignore.
2) Another new spam message arrives. Popup appears and shows details of both spam messages. I ignore.
3) Same thing happens two more times, and the popup's limit of 4 messages is reached.
4) Another new message arrives. The popup appears saying there is 1 new message, but it shows the details of the 4 spam messages that were received earlier. Forced to switch to Thunderbird and check if the newest message is spam or legit mail.

Before reading Edward's description, I thought that this was happening because the timestamps on the spam are set to future times. However, now I'm thinking its more likely that the spam messages were received on an account that somehow has priority in the list, whereas the legit messages are generally coming through on another account (which would mesh with Edward's problem, where his mail from his old account is getting displayed with priority).
Yes, i'm having the same issue. Maybe the popup should display details for the last new messages, not the first (which are still status new).
I was going to submit a new bug, but this (and also bug 375717) seems to be related, so I'm going to post here.

Suppose you have two POP accounts and you have both beep and visual notification of new email turned on, and you receive three emails that you don't read, with enough time separation for separate notifications to occur:

1) An email arrives on Account 1 - Thunderbird beeps and shows visual notification of that email.

2) A second email arrives on Account 1 - No beep and no visual notification.

3) An email arrives on Account 2 - No beep.  Visual notification does display, but it shows the unread email from Account 1 instead of Account 2.

This highlights several problems:

A) Visual notification only seems to occur when an email arrives on an account that didn't have any unread email, rather than occurring every time a new email arrives.

B) The visual notification doesn't necessarily display the message that triggered it's display -- this seems to be what other people are complaining about in this bug, i.e. it should display the newest unread messages, not the oldest.

C) Whatever the rule is for triggering a visual notification, it is not the same as the rule for a beep.  This may be intentional, rather than being a bug, but it can be a little confusing to the user who assumes there will always be a beep if there is new mail.  The reason that I say it could be intentional is that it sometimes makes sense to disable the beep if the user isn't responding to the incoming mails, e.g. to avoid annoying coworkers when someone is away from his/her desk.

While I can understand suppressing a beep if the user isn't responding, I don't see why the visual notification should be suppressed for email #2 in the example above.

Personally, when I receive an email that isn't important (e.g. I can tell from the visual notification that it is spam or not urgent), I'm tempted not to interrupt what I'm working on to pull up Thunderbird and read/trash the newly arrived email.  But, with the current behavior I really don't have the option of just leaving such emails for later, because they cause me to either miss notifications of new (possibly urgent) emails (A) or they cause notifications that do occur to be useless (B).

I've verified this behavior on Linux with Thunderbird 2.0.0.6 and also 3.0a1pre.
I totally agree with comment #4, I experience the same issues/annoyances, and would like to see it fixed. 
Assignee: mscott → nobody
Severity: major → normal
The initial issue mentioned here is still the same like bug 375717 and not only related. So lets dupe and do all the work on one place.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 375717
You need to log in before you can comment on or make changes to this bug.