crash [@ ProxyRelease_EventHandlerFunc] when opening new window with HTML Validator and Organize Status Bar extensions installed

RESOLVED WORKSFORME

Status

()

Core
Networking
--
critical
RESOLVED WORKSFORME
11 years ago
7 years ago

People

(Reporter: Miriam Frenay, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

If both the HTML Validator (https://addons.mozilla.org/en-US/firefox/addon/249) and Organize Status Bar (https://addons.mozilla.org/en-US/firefox/addon/1759) extensions are installed, opening a new window crashes Firefox.

Reproducible: Always

Steps to Reproduce:
1. Install the aforementioned extensions;
2. Restart Firefox;
3. Choose New Window from the File menu.
Actual Results:  
Firefox crashes.

Expected Results:  
A new window is opened.

Observed with the combination of HTML Validator version 0.8.3.9 and Organize Status Bar version 0.5.2. The crash occurs regardless of how the new window is opened; it was first discovered with links that open in a new window, and the crash is even triggered by starting a second copy of Firefox.

Comment 1

11 years ago
I can reproduce it in Firefox 2.0.0.3 on Windows XP.
TB31144709y  (Trigger Reason: Access violation)

The stack does not make much sense to me:

ProxyRelease_EventHandlerFunc  [mozilla/netwerk/base/src/nsRequestObserverProxy.cpp, line 64]
0x778b0c24
nsSimplePageSequenceFrame::SetPageNumberFormat  [mozilla/layout/generic/nsSimplePageSequence.cpp, line 581]
0x637020f9

and nothing more...

I tried to reproduce it in a branch debug build, 2.0.0.4pre as of today,
but I could not make it crash...
Keywords: crash

Comment 2

11 years ago
WFM, Firefox 2.0.0.3 on Linux, with the above extensions.
WFM using Firefox 2.0.0.4 on Windows XP with the above extensions.

I'm going to resolve this bug as WORKSFORME.

Timo, if you're able to reproduce this bug using a new profile and installing those extensions into it, please report back. With a clean profile and a clean installation of those extensions, I cannot reproduce this crash.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

11 years ago
In fact I already reinstalled Firefox and created a new profile because of an unrelated problem, and the combination of these extensions still gives the same problem. As Mats stated that he was able to reproduce the crash in 2.0.0.3, but not in 2.0.0.4, I'm waiting for the release of 2.0.0.4 hoping that it will solve the problem.
(Reporter)

Comment 6

11 years ago
Whoops, just goes to show that I shouldn't trust auto update. I installed 2.0.0.4 and the problem persists. I created a new profile, installed only those two extensions and restarted Firefox. Clicking File -> New Window in this case doesn't crash Firefox - I've started noticing that in some cases the crash doesn't occur, and although I haven't figured out yet what these cases are this is one of them. After closing and then re-opening Firefox however the crash was reliably reproducible just by clicking File -> New Window.
Timo, thanks for reporting back. I can reproduce now as Mats could, so reopening and moving to core.

STR:
 1. Create a new profile
 2. Install https://addons.mozilla.org/en-US/firefox/addon/249
 3. Install https://addons.mozilla.org/en-US/firefox/addon/1759
 4. Restart
 5. Do whatever HTML Validator needs on first load
 6. Restart
 7. Click File -> New Window

This will crash me every time. TB32752313E.
Status: RESOLVED → UNCONFIRMED
Component: General → Networking
Product: Firefox → Core
Resolution: WORKSFORME → ---
Summary: New Window crashes Firefox when HTML Validator and Organize Status Bar are installed → crash [@ ProxyRelease_EventHandlerFunc] when opening new window with HTML Validator and Organize Status Bar extensions installed
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: general → networking
WFM in Firefox 3.5.3 on Windows Vista, following the steps in comment 7.
Status: NEW → RESOLVED
Last Resolved: 11 years ago9 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ ProxyRelease_EventHandlerFunc]
You need to log in before you can comment on or make changes to this bug.