If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

show_bug.cgi is the only page that prefills the id in the bug_ids field for named tags functionality (new in 3.0)

RESOLVED WONTFIX

Status

()

Bugzilla
User Interface
--
minor
RESOLVED WONTFIX
11 years ago
4 years ago

People

(Reporter: Jeremy Baron, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
show_bug.cgi is the only page that will prefill the id in the bug_ids field for the named tags functionality
A quick mxr search reveals that only 2 cgi's set the var 'bugids' used by the template for this prefilling at http://mxr.mozilla.org/mozilla/source/webtools/bugzilla/template/en/default/global/per-bug-queries.html.tmpl#96 and only one is set in a scope available to the template processor when processed.

Some examples of places where this is an issue are buglist.cgi (possibly intentional, but IMO should be prefilled when there is a maximum threshold of results satisfied) process_bug.cgi, show_activity.cgi, votes.cgi, and I presume given the variable's absence from post_bug.cgi that too.  (I'll see in a second :)

Not sure the best way to do this. (I'm relatively new to the bugzilla codebase)  Given the variable name is used elsewhere for something else, maybe a new name should be chosen.  Also a UI decision needs to be made for pages like buglist.cgi with more than one bug listed. (any others that would be an issue?)

Is this important enough to take for bmo as a customization if there's a working patch? (justdave?)

Will discuss on IRC when I have time (a little busy this week and OS X has been giving me trouble :( )

btw, not sure which component this should go in so feel free to move it.
(Reporter)

Comment 1

11 years ago
The field is empty as expected on post_bug.cgi

Comment 2

11 years ago
We are going to redo some work about how tags are working. Your RFE about buglist.cgi has already been filed in bug 95722.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 372023

Updated

11 years ago
Target Milestone: Bugzilla 3.2 → ---

Updated

8 years ago
Duplicate of this bug: 534099

Updated

8 years ago
Duplicate of this bug: 534099

Comment 5

8 years ago
I just now performed the following test:  

1.  I went to <https://landfill.bugzilla.org/bugzilla-tip/> to run Bugzilla 3.5.2+.  

2.  Using an account that I previously established, I logged in.  

3.  In the footer, I selected the query "My Bugs".  Bugzilla displayed the two bug reports -- 10500 and 10501 -- that I previously generated.  The footer of the Bug List display included a section for tagging.  The "the named tag" pull-down list showed that the tag "DRoss" already exists.  

4.  On the Bug List display, I selected 10501.  The footer of the bug report page showed 10501 in the "to bugs" input area.  

5.  I updated 10501, adding a comment.  (There already was one comment, this became the second comment.)  When the bug report page regenerated with the added comment, the footer did not show 10501 in the "to bugs" input area.  

6.  I created a new bug report (10539).  When the bug report displayed, the footer did not show 10539 in the "to bugs" input area.  

7.  I reran the query "My Bugs".  Bugzilla now displayed the three bug reports that I generated.  

8.  On the Bug List display, I selected 10539.  The footer of the bug report page showed 10539 in the "to bugs" input area.  

Per the suggestion of Max Kanat-Alexander, I have reopened this bug report.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 6

8 years ago
Thanks for the information. A shorter explanation would save us who read a lot of bugmail some time, though, next time.

I agree that this is a bug and if somebody wants to patch it and the patch isn't too invasive, we can take it. (I mean, even if it's invasive, we'll take it on HEAD, but if it's going to go on the branches, it needs to be less invasive.)
Severity: normal → minor

Comment 7

8 years ago
Created attachment 417771 [details]
Bug Report Footer After Selecting Bug From Bug List

This is the footer seen at the end of step 4 of the test described in comment #5.

Comment 8

8 years ago
Created attachment 417772 [details]
 Bug Report Footer After Updating Bug Report

This is the footer seen at the end of step 5 of the test described in comment
#5.

Comment 9

6 years ago
wontfix as we are going to remove the tagging system from the footer in bug 616191,
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago6 years ago
Depends on: 616191
Resolution: --- → WONTFIX

Updated

6 years ago
Duplicate of this bug: 662197

Updated

6 years ago
Duplicate of this bug: 694760

Updated

6 years ago
Duplicate of this bug: 709075

Updated

4 years ago
Duplicate of this bug: 893453
You need to log in before you can comment on or make changes to this bug.