Firefox does not support the root file path for local files.

RESOLVED DUPLICATE of bug 143021

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 143021
11 years ago
11 years ago

People

(Reporter: Zolly, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Firefox does not support the absolute file path for local file.
Firefox only supports the relative file path.
IE support the absolute file path from root directory.

Example 1,

IE support "<script language="javascript" src="/js/shop.js">"
"/js/shop.js" can be "c:/js/shop.js" or ""d:/js/shop.js" based on its default drive. This enables us to use this same file name all over the site. Very Nice!!!

For Forefox we must use only relative file path like "<script language="javascript" src="../../js/shop.js">" or "<script language="javascript" src="../../../../js/shop.js">" based on the current file path. Very Confusing!!


Example 2,

IE support the root file path in CSS file.

H1  {
	font-size : 18px;
	background-image : url("/images/bg_title.jpg");
}

So we can use only one CSS file all over the site!!!

For Firefox we must use:

H1  {
	font-size : 18px;
	background-image : url("../images/bg_title.jpg");
}

or 

H1  {
	font-size : 18px;
	background-image : url("../../images/bg_title.jpg");
}

We must have lots of CSS files because of this just one bug.

Rgds


Reproducible: Always

Steps to Reproduce:
1.
2.
3.



It was bug of Netscape.
Firefox still has same bug as the dead Netscape!!!

Since Microsoft is making Operating System, they are very very good at file handling system.

File handling system is very important basic functions.
It must be perfect.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 143021
You need to log in before you can comment on or make changes to this bug.