incompatible add-ons, which are automatically disabled on start up, make frames drop while rendering dhtml animation

RESOLVED DUPLICATE of bug 377380

Status

()

RESOLVED DUPLICATE of bug 377380
12 years ago
12 years ago

People

(Reporter: simon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3) Gecko/20070322 GranParadiso/3.0a3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3) Gecko/20070322 GranParadiso/3.0a3

This bug is kind of hard to reproduce and maybe to esoteric, but if you stick exactly to steps described below, then it occurs every time.

Extensions, which are automatically disabled by GranParadiso, effect the the rendering of a dhtml animation [see https://bugzilla.mozilla.org/show_bug.cgi?id=229391]. Up to 2/3rds of the frames are dropped. As soon as you restart GranParadiso the rendering is fine. The skipping of frames doesn't seem to depend on a specific extension, but it seems you need at least two ore more add-ons (maybe it depends on memory consumption?).

See comments on bug 229391, especially #48 to #53 for more information.


Reproducible: Always

Steps to Reproduce:
 1. Make sure you have a few extension installed in Firefox 2.x
 2. Start GranParadiso
 3. The window "Checking for compatibility" comes up.
 4. The dialog "Incompatible add-ons, e.g Adblock, Firebug, FireFTP, HtmlValidator" comes up.
 5. Press the "Don't Check"-Button
 6. Go to http://www.speich.net/computer/moztesting/3d.htm
 7. Click on the link "big cube" and move your mouse out of the window.
 8. Some of the frames are dropped. Often up to more than 2/3rds are skipped.
 9. Close GranParadiso and restart Paradiso
10. Go back to http://www.speich.net/computer/moztesting/3d.htm. Now the rendering is ok.
11. Start Firefox 2.x and re-enable the extensions.
12. Close Firefox 2.x
13. Repeat the steps 1-12 and so forth
Actual Results:  
Many frames in animation are just dropped.

Expected Results:  
Rendering should be same independent of disabled extensions and restart browser.
(Reporter)

Comment 1

12 years ago
Sorry for double posting, you can delete this bug. Keep bug 377380, its referenced from bug 229391.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 377380
You need to log in before you can comment on or make changes to this bug.