Signature separator is not included when replying to a message

RESOLVED DUPLICATE of bug 231160

Status

RESOLVED DUPLICATE of bug 231160
12 years ago
11 years ago

People

(Reporter: agent2026, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: version 1.5.0.10 (20070221)

While the '--' separator is included above the attached signature when composing a new message, it is not include when replying to a message.

Reproducible: Always

Steps to Reproduce:
1. Create a signature file, and set your account options to attach the signature to your messages.
2. Reply to any message.
Actual Results:  
'--' separator is not included.

Expected Results:  
'--' separator should be included.

Comment 1

12 years ago
Only if you have chosen to reply on top. That's as designed, as the separator would otherwise the rest of the reply would become "part of the signature"...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 231160
(Reporter)

Comment 2

11 years ago
Don't agree.  Without the separator, the reply becomes 'part of the signature'.  It should still have the separator when the user replies on top to separate the signature from the reply.  Any quoted text is generally treated with some heading and indentation of some sort, as is the quoted text below, to separate it from the message and signature on top.

On 4/16/07, bugzilla-daemon@mozilla.org <bugzilla-daemon@mozilla.org > wrote:

    Do not reply to this email.  You can add comments to this bug at
    https://bugzilla.mozilla.org/show_bug.cgi?id=377387


    Magnus Melin <mkmelin+mozilla@iki.fi> changed:

               What    |Removed                     |Added
    ----------------------------------------------------------------------------
                     CC|                            |mkmelin+mozilla@iki.fi
                 Status|UNCONFIRMED                 |RESOLVED
             Resolution|                            |DUPLICATE

Comment 3

11 years ago
Bug 54570 is about detecting the end of signature.
(Reporter)

Comment 4

11 years ago
Completely separate issue.  I'm referring to visual separation, as well as consistency.

Comment 5

11 years ago
Yes, but the discussion is relevant. 
As you can note from that bug, there is no real "end of signature" mechanism. Therefore, it's not a good idea to use the separator when top-replying.
You need to log in before you can comment on or make changes to this bug.