Trunk Win32 Xforms busted in Pyprocessor.py

RESOLVED DUPLICATE of bug 377198

Status

RESOLVED DUPLICATE of bug 377198
12 years ago
2 years ago

People

(Reporter: nthomas, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
From the build log

...
/cygdrive/e/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/build/cygwin-wrapper /cygdrive/d/moztools/bin/nsinstall -m 644 _xpidlgen/xforms.xpt ../../dist/xpi-stage/xforms/components
Traceback (most recent call last):
  File "e:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/config/Preprocessor.py", line 465, in ?
    main()
  File "e:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/config/Preprocessor.py", line 450, in main
    pp.handleCommandLine(None, True)
  File "e:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/config/Preprocessor.py", line 196, in handleCommandLine
    self.do_include(f)
  File "e:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/config/Preprocessor.py", line 418, in do_include
    raise Preprocessor.Error(self, 'FILE_NOT_FOUND', str(args))
__main__.Error: ('', 0, 'FILE_NOT_FOUND', '/cygdrive/e/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/extensions/xforms/e:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/extensions/xforms/jar.mn')
Creating install.js...
rm -f install.js
/usr/bin/perl e:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/toolkit/mozapps/installer/makejs.pl e:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/extensions/xforms/install.jst 0.8 ../../dist/xpi-stage/xforms
 copy "/cygdrive/e/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/xpinstall/packager/common/share.t" e:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/extensions/xforms/install.template
   calculating size for ../../dist/xpi-stage/xforms/chrome
   calculating size for ../../dist/xpi-stage/xforms/components
Traceback (most recent call last):
  File "e:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/config/Preprocessor.py", line 465, in ?
    main()
  File "e:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/config/Preprocessor.py", line 450, in main
    pp.handleCommandLine(None, True)
  File "e:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/config/Preprocessor.py", line 196, in handleCommandLine
    self.do_include(f)
  File "e:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/config/Preprocessor.py", line 418, in do_include
    raise Preprocessor.Error(self, 'FILE_NOT_FOUND', str(args))
__main__.Error: ('', 0, 'FILE_NOT_FOUND', '/cygdrive/e/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/extensions/xforms/e:/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/extensions/xforms/install.rdf')
make[1]: *** [libs] Error 1
make[1]: Leaving directory `/cygdrive/e/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/extensions/xforms'
make: *** [all] Error 2
make: Leaving directory `/cygdrive/e/builds/tinderbox/Fx-Trunk/WINNT_5.2_Depend/mozilla/extensions/xforms'
firefox.exe built successfully.
firefox.exe binary exists, build successful.
Unable to find path to Talkback client. Proceeding as if Talkback was not installed.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1176463560.18064.gz&fulltext=1

I'm going to disable the Nagios check for win32-xpi/xforms.xpi until this issue is resolved.

Comment 1

12 years ago
As said in bug 377198, this is a bug of how tinderbox is set up to build xforms, and per Benjamin and preed, the fix is to not build it.

For reference, the tinderbox script explicitly specifies a native srcdir path where everything else would create a cygwin one.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 377198
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.