Closed Bug 377425 Opened 14 years ago Closed 14 years ago

Scrollbar always appears on top of DHTML layer

Categories

(Core Graveyard :: GFX: Mac, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 187435

People

(Reporter: daniel, Assigned: jaas)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: 10.4.8

- Load slacker.com (you need Flash 8 or higher)
- Expand all the station folders on the left enough to force a vertical scrollbar
- Click the "options" menu (right above the station tree)

The scrollbar appears *over* the menu.  The menu is a DHTML layer.  The strange thing about this is that when you move the mouse up and down over the menu/scrollbar overlap area, the mouseovers on the menu items fire.  So, the scrollbar is not blocking mouse events from passing, but the display is acting like an MSIE windowed form control.


Reproducible: Always

Steps to Reproduce:
- Load slacker.com (you need Flash 8 or higher)
- Expand all the station folders on the left enough to force a vertical scrollbar
- Click the "options" menu (right above the station tree) OR right click on any station name in the tree
Actual Results:  
DHTML menu displays with scrollbar over the top of it.

Expected Results:  
DHTML menu displays as the top most layer.
I forgot to say...this is for Firefox...
That is fixed on trunk, although I had problems loading the url
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 187435
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.