Right click -> edit Item opens only one edit event dialog even if multiple are selected

VERIFIED DUPLICATE of bug 378444

Status

Calendar
Sunbird Only
--
minor
VERIFIED DUPLICATE of bug 378444
11 years ago
10 years ago

People

(Reporter: Fallen, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 261553 [details] [diff] [review]
Fix opening multiple dialogs

In lightning:
* Select multiple events with CTRL
* CTRL+Right click on the last event
* choose "Edit Item"

Results:
* Multiple event dialogs are opened, one for each event.

Expected:
* Only one dialog should be opened


If this is already the way it should be, then it should also be like that in sunbird.
Attachment #261553 - Flags: first-review?(daniel.boelzle)

Comment 1

11 years ago
Comment on attachment 261553 [details] [diff] [review]
Fix opening multiple dialogs

IMO we need UI review for this handling. I see multiple options:
- open an event dialog for the last selected
- open event dialogs for all currently selected (current implementation)
- don't offer "Edit Item" at all when selecting multiple items
and possibly many more...
Attachment #261553 - Flags: ui-review?(christian.jansen)

Comment 2

11 years ago
Where is the benefit from not allowing users to open one or more event dialogs or tasks dialogs at the same time? Doing that would force users to work in a sequential way. This might be good for novice user, but it would limit users with more experience and skills. With this change it would not be possible to compare two or more events at the same time. I think we should stick to the current implementation.

Updated

11 years ago
Attachment #261553 - Flags: ui-review?(christian.jansen) → ui-review-
(Reporter)

Comment 3

11 years ago
In that case, I am morphing this to a Sunbird bug, since Sunbird only opens one dialog, regardless of how many events are selected.
Assignee: bugzilla → nobody
Component: Lightning Only → Sunbird Only
QA Contact: lightning → sunbird
Summary: Right click -> edit Item opens one edit event dialog for each selecting events → Right click -> edit Item opens only one edit event dialog even if multiple are selected

Updated

11 years ago
Attachment #261553 - Flags: first-review?(daniel.boelzle) → first-review-
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7pre) Gecko/20070813 Calendar/0.7pre.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Philipp, should we dupe this bug against Bug 378444?
(Reporter)

Comment 6

10 years ago
Sounds like a good idea
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 378444
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.