Closed Bug 377497 Opened 13 years ago Closed 8 years ago

[OS/2] Crash when attempting to print without installed printer

Categories

(Core Graveyard :: GFX: OS/2, defect, minor)

1.8 Branch
x86
OS/2
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 707864

People

(Reporter: edgar.scrutton, Assigned: mkaply)

Details

(Keywords: crash)

User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8.1.2) Gecko/20070306 SeaMonkey/1.1.1
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8.1.2) Gecko/20070306 SeaMonkey/1.1.1

I login to: https://easyweb.tdcanadatrust.com/
with ID and PWD. Display desired account. Click on 'Print" on Page and SeaMonkey crashes everytime.

Reproducible: Always

Steps to Reproduce:
1.Login
2.Display Account
3. Select "print" from on screen. 
4. Crash.


Expected Results:  
In previous versions I got the 'select printer' and it printed.

This does not happen under SeaMoney for Windows.
Some questions:

- I take it that the "print" that you select is part of the webpage? What
  happens if you use File -> Print... instead?

- Does this mean that other pages print correctly? Because we cannot really test
  some random site where we need to log in first...

- Do you get anything in POPUPLOG.OS2 for the crash?

Popuplog shows:


9-05-2006  09:57:59  SYS3175  PID 004b  TID 0001  Slot 008b
C:\MOZILLA.ORG\SEAMONKEY\SEAMONKEY.EXE
c0000005
1db70712
P1=00000001  P2=0000000c  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=00000000  EBX=00000000  ECX=00000002  EDX=01f06900
ESI=0011f870  EDI=020d67f0  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1db70712  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:0011f4b0  SSACC=f0f3  SSLIM=ffffffff
EBP=0011f4d8  FLG=00012206

XPCOMCOR.DLL 0001:00000712


(Below showed up about 10 times)
------------------------------------------------------------

09-05-2006  13:05:20  SYS2070  PID 0055  TID 0001  Slot 0092
C:\MOZILLA.ORG\SEAMONKEY\SEAMONKEY.EXE
ACCESS->XPCOMCOR.422
182

I think I will uninstall, delete all directories and try a fresh install before I report back. .  Gotta save my addresses and bookmarks and emailfiles this time :>(( 

11:00 am EST (Toronto)
I have spent 2 hours trying different things. I have installed/uninstalled/deleted several versions. Currently  SeaMonkey 1.0.8 Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8.0.10) Gecko/20070310 SeaMonkey/1.0.8. 
My conclusion is that this is NOT any version of SEAMONKEY.  Mesa2, LSS WordPro,IBM Editor and others perform properly. 
Choosing anything under the File: (Print, Print Preview, or Page Setup) causes it to exit.  As far as I know at the moment everything else is OK. I can download, read and file emails. This is not website related. I think it is something to do with the way printers are setup on my particular machine but I don't know what to do about that at the moment. 
I wonder too, if this is related to ECSMT upgrades made a week or so ago. 
Sorry, I'm just a user and can't really figure these things out well. 

Last crash yielded the following ... if it helps
-----------------------------------------------------------

04-16-2007  10:54:01  SYS3175  PID 0076  TID 0001  Slot 0092
C:\MOZILLA.ORG\SEAMONKEY\SEAMONKEY.EXE
c0000005
168b735f
P1=00000001  P2=00000007  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=00000000  EBX=0011e5ac  ECX=0041d254  EDX=00000007
ESI=1b189ddc  EDI=0041d265  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:168b735f  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:0011e1d0  SSACC=f0f3  SSLIM=ffffffff
EBP=0011e440  FLG=00012202
PSCRIPT.DRV 0001:0001735f

Change Status to SOLVED...! (:>))
Following the 'printer' track I was going to delete all my printers and start with one ... but just set the 'default printer' to the Xerox Phaser 8400.  Then SeaMonkey quit exiting on Page Preview, Page Setup, and Print.   That simple.  It's now 11:50 am  almost three hours after starting. Isn't it the Way?  Thanks for the ear.  
This does raise a question for the 'features' boys. Shouldn't you trap this error when the printer isn't there and give some sort of message.  I suppose in Windows that is the responsibility of the OS.  Error trapping the hardest part (an very important part) of programming. 
THANKS again. EDGAR
Severity: major → trivial
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Edgar, thanks for taking the time to find a workaround yourself. I had originally thought  that the problem would be somewhere else (typical OS/2 LIBPATH problem for instance), but you are right, I think it is unacceptable to crash when no printer is installed. I therefore reopen the bug report with a changed bug summary.

I recently experienced a similar problem on Linux for which I had filed bug 373666...
Severity: trivial → normal
Status: RESOLVED → UNCONFIRMED
Keywords: crash
Resolution: FIXED → ---
Summary: Attempt to Print displayed screen causes crash → Crash when attempting to print without installed printer
Peter: With OS/2 ... aka ... there's always something different and challenging. May I state my personal thanks for the work you do. 
Can we get rid of the "Show Remote Content" box on every email?
(In reply to comment #5)
> I therefore reopen the bug report with a changed bug summary.

Can you reproduce this bug ?
Do you want to confirm this bug (status) ?

(In reply to comment #6)
> Can we get rid of the "Show Remote Content" box on every email?

File a separate bug, as needed.
Severity: normal → minor
Summary: Crash when attempting to print without installed printer → [OS/2] Crash when attempting to print without installed printer
Version: unspecified → SeaMonkey 1.1 Branch
(In reply to comment #7)
> Can you reproduce this bug ?
> Do you want to confirm this bug (status) ?

I didn't manage to reproduce yet because I didn't manage to get rid of my printer object(s) yet. But I think the problem is clear enough so that I can confirm this bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: general → mozilla
Component: General → GFX: OS/2
Product: Mozilla Application Suite → Core
QA Contact: general → os2
Version: SeaMonkey 1.1 Branch → 1.8 Branch
Product: Core → Core Graveyard
Maybe this will get solved by bug 707864.
Depends on: 707864
(In reply to Peter Weilbacher from comment #9)
> Maybe this will get solved by bug 707864.

Perhaps we should make this a dupe of 707864? On a fairly new install of eCS 2.1 with no printers installed yet, Firefox 10.0.1 crashes repeatedly in a consistent manner. Plus the code has changed a lot since this bug was filed.
Status: NEW → RESOLVED
Closed: 13 years ago8 years ago
No longer depends on: 707864
Resolution: --- → DUPLICATE
Duplicate of bug: 707864
You need to log in before you can comment on or make changes to this bug.